
 

Instructions for Building the FY10 Budget 
in Pillar 

In this Pillar plan file, you will have access to all accounts that are currently part of your budget. It 
includes your original base budget through the close of January 2009. It also includes the detail for 
your staffing plan through the month of January. Budget or staffing plan changes that were made 
after January close will not be reflected in the Pillar file. Plan files must be updated to reflect your 
FY10 budget. 

Pillar is currently only used as a data entry tool to build your budget, and will not make automatic 
calculations for line items such as benefits. Calculations must be made outside of Pillar and then 
entered into the appropriate subcodes in the Pillar file. 

These instructions assume basic knowledge of Pillar. If you need additional help, you may refer to 
the “Pillar Users Guide” on our web site or contact the Budget Office. 

In this document you will find step-by-step instructions that will guide you in updating and 
completing your Fiscal Year 2010 budget submission. 

• Entering/Updating the Staffing Plan 

• Entering/Updating Non-Staffing Line Items (benefits, student wages, supplies, etc) thru 

data entry, copy/paste, or importing. 

• Printing Budget Submission Reports 

Opening your Pillar Plan File 
 To open Pillar plan file 

1. Double-click on the Pillar plan file 

 

2. Enter the user name and password (included in budget packet to senior officer) 

 

Once you have logged in, you will see the Table of Contents as shown below. Click on the 

“Expenses” module on left-hand side to show its contents. These are the reports/worksheets that 

will be used to build your budget. 
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Entering/Updating the Staffing Plan 
The Staffing Plan contains all budgeted positions thru January month end. Any changes to staffing 
plans made after the end of January may not be reflected on this staffing plan. Through this process, 
you will update staffing plan line items to reflect your plans for FY10. 

 Double-click on folder “>>budget manager: FY10 Budget Entry Worksheets” 

 

 Double-click on “>>budget manager: A WS1a Staffing Plan Data Entry” to start 

updating your staffing plan for FY10 
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Updating Existing Line Items  
1) Account # - to change the account #, enter the new number or choose from choices list  

2) Account Description - updates automatically based on account # selection 

3) Subcode # - Verify that this is the subcode to which salaries will be charged in FY10. If it is 

not, make sure it is corrected to match what you have on the PAFs. 

4) Position # – Position # is assigned to positions by Human Resources. Do not change these 

unless they have been changed by HR. If a position has not been assigned, enter “New”. 

5) Line Item (Employee Name) – If a position has become vacant, enter “vacant” here. Or if it 

has been filled by someone else, change the employee name. 

6) Position Title – updates automatically based on position # selection. 

7) FY09 Budget – Original budget as of January 31. Do not change. 

8) FY10 Budget – This is the base salary that will be charged to this account in FY10. Be sure to 

budget the full year’s salary. 

9) Grade ID – Any change in position grade should be reflected here. 

10) FTE ID - The FTE should reflect the employees’ percent time of work. Employees paid from 

multiple accounts should be budgeted in each account, with the FTE in each account reflecting 

the percentage of their distribution from that account. The total FTE should not be greater than 

1.00. 

Adding a New Position 
1) Scroll to the bottom of the report and on the first available row, enter the account # 

2) Fill in the rest of the fields as indicated above “Updating Existing Line Items” steps 3- 10. 

3) Once all fields are completed for the line item, it will sort into place by account. 

Deleting a Position 
1) Click on the black square at the far left of the row to be deleted. This will select the entire line 

item. Go to Line-item > Delete Expense 

Budgeting Staff on New Accounts  
1) You will not be able to add positions to new accounts if we have not added the accounts to your 

Pillar plan file. Pillar is updated with new accounts through the end of January. Any accounts 

created after that date will need to be manually added by the Budget Office. 

a) To get an account added/changed on your Pillar file, call the Budget Office and drop your 

Pillar file in your budget folder. Once account information is changed, the Pillar file will be 

sent back to user via the server for completion. 

Once all staffing plan line items are up-to-date, save the file and close the report. Now you will 
need to update all non-salary line items. 

 

Tip: File > Save often to avoid losing your work. 
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Entering/Updating Non-Salary Line Items 
 Double-click on the folder “>>budget manager: FY10 Budget Entry Worksheets” 

 

 Double-click on “>>budget manager: A WS3a Operating Budget Data Entry” to start 

building your operating budget line items. 

 
This report is formatted so that you can enter non-staffing plan line items directly into it. At the 
beginning of each account, you will see staffing plan line items that were updated on the staffing 
plan worksheet “>>budget manager: A WS1a Staffing Plan Data Entry”. 

On this worksheet, you are also provided with actuals from the prior year and the current year 
original base budget, which may be helpful in determining how much to budget for the next fiscal 
year. You do not need to update these numbers. You will only be entering a budget for FY10. 

Updating existing line items 
1) Line items that had activity in FY08 or FY09 are included on this worksheet. 

2) Go through the report and enter budgets for line items that you want to budget for FY10. 

3) There are no calculations associated with any line items, so remember to budget total benefits 

associated with staff salaries. 

Adding new line items 
1) Scroll to the bottom of the report until you see a blank row. 

2) Enter an account number by typing it in or select it from the choices list by clicking on the “up” 

arrow. 

3) Tab to Subcode and enter the new subcode or choose from the list. 
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4) Tab to FY10 and enter the budget amount 

5) Do not enter any information under “Line item (Employee Name)” field. This field is only 

used by line items that are part of the staffing plan. 

Deleting a line item 
1) Click on the black square to the left of account # to select the row 

2) Go to Line-Item > Delete Line Item 

a) To undo a “Delete”, select Edit > Undo Delete Expense. You can only undo the last 

action. 

Deleting an entire account 
1) Selecting a range of line items 

a) Click on the black box to the left of the first line item to be deleted, and keeping the mouse 

button pressed; drag the mouse downward until you have selected the range of line items 

to be deleted. (You can also use ctrl-click and shift-click to select multiple items.) 

b) Go to Line-Item > Delete Line Item 

2) Searching for entire account to delete 

a) Go to View > Search 

b) Search for the account # you want to delete (use search instructions in section below) 

c) Go to Edit > Select All to select all visible line items 

d) Go to Line-Item > Delete Line Item 

Working with one account at a time 
1) Go to View > Search 

a) Type “Account #” into the blank box under Field, or click on blank box under Field and click 

the up arrow to the right. Click on Dimensions and then Account # and click OK. 

b) Under Condition, enter “equal” from drop down menu 

c) Under Value, enter the account # you want, including the dash (ex. 2-99920), or select 

from the drop down menu. 

d) Click Search 

See example: 

 
This search will yield all those line items that make up the budget for Account # 2-99920 only. To 
search for multiple accounts, enter a second line after the “or” operator in the search window. 

 

Tip: File > Save often to avoid losing your work. 
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Building Your Operating (Non-Salary) Budget by 
Copying or Importing 
For larger budgets, there are options other than manually inputting budgets into report “>>budget 
manager: A WS3a Operating Budget Data Entry”. 

• You can copy prior year budget and paste into FY10 budget column. You can also adjust by 

a percentage if necessary. 

• You can export Pillar data and work on Excel, then import the budget back into FY10. 

Regardless of what method you use to build your operating budget, it is recommended that you 
follow the data entry steps for Staffing Plan line items as indicated at the top in section 
“Entering/Updating the Staffing Plan“. 

Copying FY09 Budget into FY10 
 Open the “FYXX Budget Miscellaneous Reports” folder 

 
In this folder you will need to use the first two reports (MS 1a and MS 1b) to update the budget for 
both Revenue and Expenses. If you do not have revenue line items, simply skip MS 1a. 

 To Copy Revenue Line Items 

1) Double-click on “>>budget manager: MS 1a Revenue Budget Copy/Paste”. This report 

searches for all line items that hold revenue budgets. Note that subtotals are turned off at the 

account level. 

a) Click on the FY09 Header to select column 

b) Edit > Copy 

c) Click on FY10 Header to select where amounts need to be pasted 

d) Edit > Paste.  
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 To Copy Expense Line Items 

1) Double-click on “>>budget manager: MS 1b General Operating Copy/Paste” 

a) Repeat steps a through d as indicated above. The General Operating Copy/Paste report 

searches for all Expense Line items that currently do not have information on the “Line 

Item (Employee Name)” field. This report excludes any expense line items that are part 

of the staffing plan, which have already been updated/completed. 

Exporting/Importing 
Follow these steps to export your budget to Excel and then re-import into Pillar. It is not 
recommended to import staffing plan line items. It is best to manually update them as indicated 
above.  

From the miscellaneous reports folder, you will use both Line Item Export and Line Item Import. Both 
reports are already set up with the required columns for exporting and importing. Note that this 
report will exclude any line items that are part of the Staffing Plan. 

 Exporting the budget 

1) Open “>>budget manager: MS 4a Line Item Export” 

a) Go to File > Export 

b) Fill in the File Options, asc separators, and file name as indicated below. Click “Browse” to 

choose what directory to export and give the file a title. Click Export. 

 

Make sure to 
uncheck this 

 

2) Working with Excel or “Asc” file 

a) Using Excel, navigate to the location indicated above during the export and open “budget 

export.asc” thru the wizard.  

b) When the wizard prompts, open the file using the same options as those on the exported file. 

c) Subcode # column must be opened as “text” to avoid losing any preceding zeros in 

subcodes such as revenue code 0100. Pillar requires a 4 digit subcode number. 

d) Once in Excel, save file as Budget Import.xls. This is where you will do your budget 

updating for FY10 
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 Preparing the Import “txt” file 

Once the budget has been updated in Excel the file must be converted to “txt” prior to importing into 
Pillar. You will also need to format the report to show only the required columns (Account #, 
Subcode #, FY10, and Line Item (Employee Name). See example below. 

IMPORTANT 

There is an importing bug on Pillar, where it will not upload data unless the “Line Item (Employee 
Name)” field contains text. We use this field for the Staffing Plan only and do not want text imported 
into it. In order to get around this, prior to converting the Excel file to “txt”, enter blank spaces “…” 
in the “Line Item (Employee Name)” field. Enter it once on the first row and then copy the 
contents of that field and paste onto the entire column. 

To create the”txt” file, go to File > Save as Excel. Change the file type to “txt” and label the file 
“budget import.txt”. Include the same file options as those required by Pillar. See file import options 
below. 

 Importing the “budget import.txt” file into Pillar 

 
 

1) Open “>>budget manager: MD 4b Line Item Import” 

a) The Pillar report is already formatted with the required columns for it to import an “asc” or 

“txt” file. 

Tip: It is always a good idea to write down totals already on Pillar prior to importing new data. Add 
up the current totals to what you plan to import and make sure that the sum of the two is correct 
once the import is complete. If the totals are not what you expected, something might have been 
overwritten, not imported, or may not be visible due to current search criteria on the report (if any). 

2) Go to File > Import and locate the formatted “budget import.txt”. 

a) Click Import. 
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3) Enter the import options as indicated below. 

 
 

4) An ‘Imperror” file will be created which will indicate which, if any, line items did not import. 

 

5) When all data is imported, you will see this message:  

Write down this 
path to locate 
imperror file 

 
If any line items were skipped, you can open the “imperror” file to troubleshoot why line items were 
not imported. 

Tip: write down the path of the imperror report in case you need to open it for troubleshooting. 

Printing Budget Submission Reports 
Regardless of what method was used to build your budget on Pillar, you will need to complete the 
process by printing the reports listed below and including them in your hard-copy budget submission. 
Please be sure that the detailed Staffing Plan and Account Summary or Revenue and 
Expense by Subcode (for Auxiliaries), is approved and signed by your senior officer before 
submitting to the budget office. 

• Staffing Plan 

• Account Summary 

• Revenue & Expense by Subcode (for Auxiliary units only) 
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 Open the folder >>budget manager: FY10 Budget Submission Reports 

 

Print Setup 
Print set up may change between different platforms. When you open a submission report, make sure 
it fits the page horizontally before printing. If you see a page break going down the report it 
indicates that the report goes over to a second page horizontally. To fix this prior to printing, go to 
File > Page Setup and select “Fit Horizontally to 1 Page (s)”. Click OK and then print report. 

 
 

The Pillar plan file must be submitted to the budget office via the depts2 server using a Novell 
connection or Netstorage. For instructions on how to connect to the server, go to our web site and 
enter the following URL: 
http://www.brown.edu/Administration/Budget/systems/ConnectingDepts2.html  

If you have additional questions on how to connect to the server or how to use Pillar, please contact 
the Budget Office. You may also refer to the Pillar Users Guide on our web site on how to use Pillar.  
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