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Last Time:

 Finish Surface from Boundary
Curve

 Free-form (Style features)

Tonight:
e Introduction to Assemblies
* Exploded Views
» Assembly drawings

e X-sec

» Exploded

 Tables

« BOM

 Inclusions




Assemblies

Assembly represent how components interact with eac h other
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Assemblies

In assembly files components are constrained, eithe r to other
parts Or to datu mS [= BLOCKS {Active) - Pro/ENGINEER Education Edition

File Edit Wew Insert Analysis Info  Applications Tools Manikin  Window  Help ‘
[DeusaqivesmripEen - [Drgvaadstoh]eoald
AR

o Select ikems such as Dimensions, of other features For editing

83 Select ikems such as Dimension, Section(s) or Features For editing
® Datum planes will be displayved.

® Spin Center will not be displayed.
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Assemblies
Assembly Dashboard

* There are wide
variety of options
available

* We really only need
the Placement and
Move tab for 95% of

operations
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Assemblies
Assembly Dashboard — Placement Tab
» Constraints are applied in Placement
» References are selected from
Assembly and Component being
placed
» Variety of Placements:
 Align — Equal surface normals
» Mate — Opposite surface normals
* Insert
e Tangent
» Constraints can be applied as

Coincident, Offset or Oriented
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Eile Edit Yiew Insert Analysis Info  Applications Tools Manikin ‘Window Help

[D2Ed0tvey 2BBEsnc @3- 0

fzz 7 2 % ||

e’

gy Select offset aligning surface or datum plane on other part,

[ LD' o Juserpefined = {3 algn =T - [zes - % STATUS
Placement Mowve  Flewbilty  Properties

Bo [1| = Setl (UserDefined) ¥ Constraint Enabled
M2l | [ PosTBLOCKAIGHTF1 CZ”S"E"”‘ e
| Al -] Fi
Toc| | [EpasMAGHTFioaTUl | | 12 el o
Align Offzet
Align | 17T offset i | B
Mew Congtraint
Mew Set Skatuz
Fully Constrained

’(




Assemblies

Assembly Dashboard — Move Tab

* Allows user to position component in

space prior to applying constraints
» Sometimes necessary when
components are dropped in amongst
many components
« DOES NOT TAKE THE PLACE OF
CONSTRAINTS
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# Click left button in model window ko drag component being assembled.
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Flacement | Move Flexbilty  Properties
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Assemblies

DESIGN INTENT is as important in modeling Assemblie s as in Components
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EXERCISE — Assemblies

Assemble the flanged pipe joint as shown below
* Download flange_connection.zip from the

supporting materials page

» Set Working Directory
 Extract file to working
directory

* File > New > Assembly

* pipe_joint.asm

= PIPE_JOINT {Active) - Pro/ENGINEER Education Edition

Elle Edit W¥ew Insert Analysis

Info  Applications Tools Manikin  Window Help
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3o || =] &
Shy

oA > | Settings * I

PIPE_JCINT, ASM

i) PIPE_FLANGE.PRT

© (] PIPE_FLANGE PRT
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EXERCISE — Assemblies

* Insert > Component > Assemble

» Select pipe_flange.prt
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EXERCISE — Assemblies

* Click on the Move tab

* LMB in graphics window

» Translate part

* LMB again to drop part

* You don’t have to do this

everytime you place a

part, but its nice to know ‘ A B o

Fek|edexe=~ne

when you need it
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EXERCISE — Assemblies

* Click on the Placement tab
» Select the RIGHT plane on
the component

» Select ASM_RIGHT plane

 Select Coincident from the

Offset drop-down
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EXERCISE — Assemblies

*Select the FRONT plane on

the component

» Select Coincident from the

Offset drop-down

| [ZgASM_RIGHT FIDATU "
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EXERCISE — Assemblies

«Select the TOP plane on the
component

» Select ASM_TOP plane
 Select Coincident from the
Offset drop-down

* Click the Done check
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EXERCISE — Assemblies

* Insert > Component > Assemble

» Select pipe_flange.prt again

= FLANGE_JOINT {Active) - Pro/ENGINEER Education Edition
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EXERCISE — Assemblies

* Define additional constraints
between FRONT and ASM FRONT
as well as TOP and ASM TOP oo iz

Elle Edit Wiew Insert Analysis Info  Applications TIpols Mankin Mindow Help
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EXERCISE — Assemblies

* Insert > Component > Assemble

b O p e n WaS h e r. p rt I FLANGE_JOINT (Active) - Pro/ENGINEER Education Edition

File Edit “iew Insert Analysis Info  Applications Tools Manikin  ‘Window Help
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EXERCISE — Assemblies

* Move the component (if

Jl@ll@%ﬂmmr}é%ﬁé-m {JE%%WQ&@@E&@%H‘QSBT\ @T%-&TI?’I

necessary) to find it again

STATUS : Patily Do 03 nlv] -&

» Select the face of the washer

Dftset
1 e Coircident ] :“ND'T DEF‘EJ_

« Select the face of the flange 2

(Design Intent!!)

» Select Mate from drop-down
» Select Coincident from drop-
down

e Click Done
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EXERCISE — Assemblies

* Note after these two

[ FLANGE_JOINT (Active) - Pro/ENGINEER Education Edition
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EXERCISE — Assemblies

» Assemble a second washer
in the same way on the other

side of the flange

= FLANGE_JOINT (Active) - Pro/ENGINEER Education Edition

Ele Edit View Insert Analysis Iofo  Applications Tools Mankin Window Help

Depagzlvei bRt - Brgnaalstsnlee oo aiske

® Hidden lines will not be displayed.
* Hidden lines will appear in grey.
® Shaded model will be displaved

B | & e

Shaw ¥ Settings ¥

FLANGE _JOINT. ASH
£7 HSM_RIGHT
£7 ASM_TOR
{7 ASM_FRONT
s ASM_DEF_C5YS
(1] PIPE_FLANGE.PRT
{71 PIPE_FLANGE.PRT
] WASHER.PRT
-] WASHER PRT
- dp Insert Here

& Mode| wil be displayed in wireframe display. _I

i 3—;1
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EXERCISE — Assemblies

* Insert > Component >
Assemble
» Assemble bolt.prt
» Select the outside cylinder
surface of the bolt
 Select the surface of the
through hole
* NOTE: this will create an
Insert constraint
» Mate the head of the bolt to
the washer
e Click Done
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@8 Brown University

EXERCISE — Assemblies

* Insert > Component >
Assemble

» Assemble nut.prt

» Use an appropriate set of
constraints to put nut on the
bolt

e Click Done
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EXERCISE — Assemblies

* In the Model Tree,

= FLANGE_JOINT {Active) - Pro/ENGINEER Education Edition

Select the tWO File Edit ‘“iew Insert Analysis Info  Applications Tools Manikin  Window Help
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o> Selact mating surface o datum plane on other part,
» Axes will not be displayed.

« RMB, Group b |2 o]

Show * I Settings I
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EXERCISE — Assemblies

« RMB on the Group
 Pattern

» Select Axis Pattern

 Select 6 entities

» Select 60deg

separation

* Click Done

= FLANGE_JDINT {Active) - Pro/ENGINEER Education Edition

File Edit Wew Insert Analysis Info Applications Tools Mankin  Window Help
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[n ]
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Dimenzions Tiatle Dimensions Feferepces Tzables Optione: Properties
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7 BSW_TOR ~ &
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ANGE.PRT Y 1

n 1 of LOCAL_GROUP @
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EXERCISE — Assemblies

« NOTE: If we had
assembled washers,
nut and bolt to first
feature in part model,
we could have used
a Reference Pattern
 Try this.
* Delete Pattern
* Redefine
component
placement

 RMB > Pattern

IE FLANGE_JOINT (Active) - Pro/ENGINEER Education Edition

Ele Edit View Insert Analysis

Info  Applications

Tools Mankin ‘Window Help

D085 ||ood bR EREN
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o> Select a Datum Axis to define the pattsrn center,

# Specified section has been remov
* Feature redefined successfully.
® axes will not be displayed.
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w7 BSM_RIGHT
L7 85M_TOP
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IGE.P

_FLANGE.PRT

(71 PIPE_FLANGE.PRT
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EXERCISE — Exploded View

» Create a general view that

effectively displays

I= FLANGE_JOINT (Active] - Pro/ENGINEER Education Editio

File Edit “ew Insert Analysis Info Applications Toals

components

!
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® fssembly components have been successfully unexploded.
® axes wil not be displayed,

& Datum planes will not be displayed,
® FLANGE _JOIMT has been saved.

g | & | m| 48

Show * | Setlings * |

» Once you're happy with the

orientation, open View

Manager

(7] FLANGE _JOINT ASM
71 PIPE_FLANGE.PRT
[ PIPE_FLANGE PRT
[-[] Pattern 1 of LOCAL_GROUP
[£-5% Group LOCAL_GROUP
[ WASHER.PRT
([ WASHER FRT
{71 BOLT PRT
H (8 NUT.PRT
5§ Group LOCAL_GROUP_1
[#-7¥ Group LOCAL_GROUP_2
59 Group LOCAL_GROUP_3
5§ Group LOCAL_GROUP_4
[#-5% Group LOCAL_GROUP S

 Start the view manager

NEEEIR)
% Yiew Manager

Start the view manager
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EXERCISE — Exploded View

» To Save the Orientation...

Select the Orient tab

Select Edit

Click Save...

Check to save orientation

Name the orientation

Click OK

Toggle between another
orientation and this one to make

sure it's saved

x
Simp Rep | Style | Haen I
Explode Orient | Al

Diefaul
Back

Bottarr

(el Edt~ Display~
M ames
Redefin

Sawve modified states

Hemaove
Fename

COpy

Fromt
Left
Right
Top

.|F Orientation
[ Simplified Bep

[ Shile
[v Explode

[rescription I .
[¥ Save Display Elements

splnde.

[Mat Modified]

[Mat Moadified)

| 4

Drefault Explode

| 4




EXERCISE — Exploded View

| x

» Create an Explode Display ot | o [
Explode | Orent | AN

@ select the Explode tab @ .| ciiv| vipla-|

@ Seclect New d“—ames ' |
manual

’ C“Ck Return o Default Explodef+]

Froperties > | Cloze |




EXERCISE — Exploded View

» Create an Explode Display (cont.)

@ select the Properties tab

@ Seclect Edit Position

@ Select a Motion Reference (Sel Plane)
@ Sclect the ASM RIGHT plane

@® Select a component to move

x
Simp Rep I Shyle | Haeo
Explode Orient | Al
Mew | Edit~| Display ~ |

M armes
m Sing Fee

Default Explode Explode

@ = /-

|
= [ Explode Position

[rient

x|

— d Component ————————
L3

— Mation Type

[tem

;g"‘ Edit Po

% Translate

" Copy Pos

" Defaul: Expld
" Reset

— Mation Reference

I Sel Plane j

’ k ||a1_F|IGHT:F'I[D.-’-‘-.TLIM PLAME])

<< List |

— Matian Ihcrements:
Translatiunl Smooth j
— Position
Relative| 0.000 | 0.000
IIhda I Reda | F'referenu:esl

Cancel |
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el
EXERCISE - Exploded View

* Move all 6 bolts off the flange parts

I FLANGE_JOINT {Active) - Pro/ENGINEER Education Edition =

m BOLTPRT

Sel Plane
B° | % A & |[1_RIGHT
(7] FLANGE_IDINT . ASM |7
e 7 BSM_RIGHT
7 EM_TOR

Smoo
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EXERCISE — Exploded View

» Select the center axis as a Motion

Reference and slide the bottom

= FLANGE_JOINT {Active) - Pro/ENGINEER Education Edition

flange back

File Edit VYiew Insert Analysis Info  Applications Tools Manikin Window Help

I= Explode Position El

— Selected Component ———————
| & |PIPE_FLANGE.PRT

— Motion Type
%" Translate
" Copy Pos
" Default Expld

EEEEEEEEY Y =

B am s te ik

i Feset

A

v

— Maotion Reference ——————————————

5 Select componentis) to move,

g2 Left button ko drop. Middle button to abart,
o Select componentis) to move,

* Axes will not be displayed.

B |2 | @] 44l

Shaw = I Settings ™

[TI FLANGE _JOINT ASM
{7 A5M_RIGHT
/7 ASM_TOP
-4 F BSM_FRONT
B psM_DEF_CSYS
-] PIPE_FLAMGE.PRT
-] PIPE_FLANGE PRT
=[] Pattern 1 of LOCAL_GROUP
=-F¥ Group LOCAL_GROUP
B[] WASHER.FRT
-] WASHER.PRT
I-(7] BOLT.PRT
[ MUT.PRT
9 Group LOCAL_GROUP_L
9 Group LOCAL_GROUP_2
-7 Sroup LOCAL_GROUP_3
-7 Group LOCAL_GROUP 4
5§ Group LOCAL_GROUP_S
- o Insert Here

o]
-

Explode Staba M ARL AL

d — Position

k || (REVOLVE_1):PIPE_FLAMGE

— Maohian Increments ——————————
Translatiu:unl Smooth j

Relative| 6729 |

IIndo I Fedo | F'referenu:esl

Cancel |
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EXERCISE — Exploded View
» Select the ASM_RIGHT datum

plane again and move the 6 nuts off

the pipe flange

I FLANGE_JOINT (Active) - Pro/ENGINEER Education Edition

File Edit “iew Insert Analysis Info Applications Tools

Manikin  Window Help

@ Explode Position

— Selected Component

| & [NUTPRT

— Motion Type

% Translate
" Copy Foz
i~ Default Expld

EEEEREIEEE

Wi |Argvaa@sEsn

i~ Reset
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g A4l e]

— Mation Reference

o Select companent(s) ko move,
grLeft button to drop. Middle button ko abort,
g Select component(s) ko move,

8o |&| | &R

Show = | Settings ™ I

[T FLANGE _JOTNT . 45M
- F ASM_RIGHT
- F BEM_TOR
£7 BSM_FRONT
2 ASM_DEF_C5YS
-[7] PIFE_FLANGE FRT
-] PIFE_FLANGE FRT
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H (] WASHER.PRT
B[] WASHER.PRT
[CJ BOLT.PRT
[1 MUT.PRT
#- 79 Group LOCAL_GROUP_L
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-9 Group LOCAL_GROLP_3
-G} Group LOCAL_GROLP_4
-9 Group LOCAL_GROUP 5
L. dp Insert Here
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Relative| 0527 |
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Undo | Hedo |

Preferences |

Cancel |
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EXERCISE — Exploded View

* Move washers back

on to corresponding

p arts IE FLANGE _JOINT (Active) - Pro/ENGINEER Education Edition

File Edit Wiew Insert Analysis Info  Applications Tools Manikin  Window Help

jngEgqa|oay =k EEEEuC]
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« Select Copy Pos ;.- .~

;
x rx X

C

&> Select component ko copy position From,
- &> Select componentis) ko move,
[ ] S e e Ct e It e r n ut & Select component ko copy pasition From,
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EXERCISE - Exploded View

» Select center axis again

and move washers so they

[E FLANGE_JOINT {Active) - Pro/ENGINEER Education Edition
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BEEEEEEIEE T T =t

|Brgwaads el

EEEE

are off all other components |, .« v

gLeft button ko drop. Middle button to abart.,

o Select companent(s) to move.

* fxes will not be displayed.

* Assembly components have been successfully exploded.

B | & | | 5]

Show * I Settings ™ |

FLANGE_JOINT.ASHM
- f 7 BSM_RIGHT
- f 7 BSM_TOP
7 BEM_FROMT
A ASM_DEF_C5YS
(] PIPE_FLAMGE PRT
(] PIPE_FLAMGE FRT
- [2] Pattern 1 of LOCAL_GROUP
=5 Group LOCAL_GROUP
[ 7] WASHER.PRT
-1 WASHER.PRT
-1 BOLT.PRT
H I MUT.PRT
[#-59 Group LOCAL_GROUP_L
9 Group LOCAL_GROUP_2
-9 Group LOCAL_GROUP_3
79 Group LOCAL_GROUP_4
[#-5¥ Group LOCAL_GROUP_S
= Insert Here

-E-E
-~

Evplode StateiMANLAL(+)

|. | Srnart | ’!‘SI ,&”

BCB — Mar. 8, 2012

EN1740, S2012



EXERCISE — Exploded View

» Create Offset Lines

connecting
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EXERCISE — Exploded View

* Return and toggle off

FLANGE _JOINT {(Active) - Pro/ENGINEER Educ.

exploded display

File Edit Wew Insert Analysis Inofa  Applications Tools Manikin  ‘Window Help Simp Rep | Siyle | Ksec I
o [ - E =] Oe Oed r=1 = + AE Explode Orient | All I
lDeEaGa|lvoad aREiEEn ] | Brgnaaantal | o0 o0
i % - Edlv  Display ™ |
JLZ J'a";j(a“ D%H k?‘

® Assembly components have been successfully exploded,
* Assembly components have been successfully unexploded,
# Assembly components have been successfully exploded.
# Assembly companents have been successfully unexploded.

=lsl

Show * | Settings ¥ |

FLANGE_JOINT, ASM
- £F BSM_RIGHT
£ F B3M_TOP
<47 BSM_FRONT
A SM_DEF _C5vS
(4[] PIPE_FLANGE.PRT
(1 [_] PIPE_FLANGE.PRT
21~z Pattern 1 of LOCAL_GROUP
=% Group LOCAL_GROLP
] WASHER.PRT
<[] WASHER PRT
-1 BOLT PRT
-l MUT.PRT
¥ Group LOCAL_GROUP_1

79 Group LOCAL_GROUP_4
¥ Group LOCAL_GROUP_S
- [ Offset Line id 150
-1 Offset Line id 154
-0 Offset Ling id 158
[ Offset Ling id 162
- [ Offset Line id 170
- [0 Offset Line id 174
-0 Offset Ling id 175
[ Offset Ling id 182
- Offset Line id 186
-1 Offset Line id 190
-0 Offset Ling id 194
[ Offset Ling id 195
-1 Offset Ling id 202
- [ Offset Line id 206
(3 Offset Ling id 210

M ae:s

Defaul

Save. ..

Toggle Explode Status
Remove

Renamne

Zop

Descripkion

start] | (5020210 Jectus2.




EXERCISE — Exploded View
* SAVE, SAVE, SAVE
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EXERCISE — Exploded View

 While we'’re at it....create
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Assembly Drawing
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EXERCISE - Assembly Drawing

» Create an assembly
drawing or the pipe flange
assembly
* Begins in same way
as for components
» Be sure to use same
name as Assembly
e For Format, use
c_bom.frm that came with
the files for tonight’s lecture
(should be in working

directory)
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EXERCISE - Assembly Drawing
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EXERCISE - Assembly Drawing

» Add two projection views
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EXERCISE - Assembly Drawing
» Add Bill of Materials
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EXERCISE - Assembly Drawing

» Add Bill of Materials
balloons (cont.)

 Create Balloons

» Show All
» Arrange balloons so they
make sense

« Edit Attachment
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EXERCISE - Assembly Drawing

* Create a second sheet

for the exploded view
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EXERCISE - Assembly Drawing
» Set View Display and
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