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Last Time: Tonight:

« Shared data e Intro to Top-Down Design
 Copied Geometry  Fundamentals
« Component Operations » Skeletons

e Family Tables




AutoCAD Next Up

* We’'re going to tackle an introduction to AutoCAD in the next few lectures
» Please go to Autodesk’s educational community site and register

o www.Autodesk.com/edcommunity

» Once registered you'll be able to download AutoCAD 2012

* Please do so in anticipation of the lectures to come




Drawing Tips for Project
Things To Keep In Mind:

» Cross-sections
* Need a SINGLE LETTER name
* Must be accompanied by section arrows
* Don’t leave dimension on the object
* Provide good spacing for the dimensions
e Don’t cross dimension and extension lines
* Don’t leave geometry shaded on drawing (perspective view included)
» Make sure you use a drawing format (title block)
* Include appropriate note for CTFD (provided on supporting page)
« DON'T double dimension
* HIDE DATUM FEATURES ON DRAWING!!




Top-Down vs. Bottom-Up

Let’s say you wanted to design this....

Aeft - http://a_llw.orlsicar's’.bgrfﬁ-/.wordpress/?p:2208"




Top-Down vs. Bottom-Up

Top-Down would start with this.....

...then figure out what would fit, then place the
engine, bumpers wheels, etc....




Top-Down vs. Bottom-Up

Bottom-up would start with this stuff.....

...and start putting them together




Top-Down vs. Bottom-Up

Top-Down: Bottom-Up:

Benefits Benefits

* Product needs to be fairly well » Does not need well defined
defined, so you're starting with the structure to start

answer  Very flexible

* Facilitates large assemblies well Drawbacks:

 Very effective way to work in

. » Team needs to communicate more
cross-functional groups

frequently
Drawbacks: « Can get unwieldy in large
e Limits flexibility assemblies

e Must have team buy-in

Real World is going to be a mix of these philosophi es




Top-Down Tools
There are a number of tools available to manage and  facilitate top down design
» Skeletons
» Data sharing
* Published
» Copied
« Component operations — Merge, Cut
« Simplified reps
« Shrink Wrap

« Many others




Skeletons

Skeletons provide:

* Product layout and envelope

» Components interface locations and size
* Product volume

» Connections and mechanisms




Skeletons — There’s a lot of rules

FROM THE PRO/E MANUAL.:
Before creating a skeleton model, consider the following points:

» Only one motion skeleton can be created or inserted in an assembly.

» Multiple standard skeletons can be created in an assembly when the

multiple _skeletons_allowed configuration option is set to yes.

* A skeleton model is similar to any other assembly component. It has features, layers,
relations, views, bodies, and so on.

» External reference control settings can be used to restrict geometry and assembly
placement references to skeleton models only (Edit > Setup > Ref Control > Skeleton
Model). These options control references for all skeletons in the assembly.

» Skeleton models can maintain their own family tables. This means that assemblies can
maintain different skeleton instances across a family table.

* All simplified representation functionality available in Part and Assembly mode is available
for skeleton models (beginning with Pro/ENGINEER 2001).

» Skeleton models can be selected By Rule when managing simplified representations.




Skeletons

In the end, Skeletons are pretty simple

» A “Skeleton” can be any part comprised of datum planes, axes and
curves that define a product
* If created as a standard part, Skeleton rules won't apply

» This may not be all bad




EXERCISE - Top-Down Design Tools

We'll illustrate the use of Top-Down tools withar  elatively simple product




EXERCISE - Top-Down Design Tools

Begin by creating a skeleton

e Create a new

- Argwaa@sTesR 8 a ool |q Lk e

assembly > grinder.asm

(7] GRINDER. &5
47 ASM_RIGH
4T ASM_TOP
A7 ASM_FRO 2w
5éxaSM_DEF,  Elen
Lo Insert Hes

* Insert > Component >

Create

 From Component Type Sub-type
() Part (*) Standard
Create dialog Select (O Subamermblie O Motion
Qsompins
Skeleton Model SBhleliem
() Envelope

* From Creation Options

E3

— Creation Method

) Copy Fram E iz
e = [

M arme

Cammon harme

Select Empty

() Create fegtus

I= Creation Options

g

ting
[ atiims

Cancel




EXERCISE — Top-Down Design Tools

° Notlce In the Model Tree the B GRINDER (Active) - ProfENGINEER Education Edition

Eile Edit Yiew Insert Analysis Info  Applications Tools Manikin  Window  Help
addition of the Skeletonasthe | 1 =y &g 0 ooy B iR w -
f| rst featu re = Ch_ecked'feature types wil be displayed in the madel tree,

% m |5

[ Shgw‘l’][ Settingr"]

» Skeletons are always

GRIMDER., A5M
[+ [ =RINDER,_SKEL.PRT:
£ F ASM_RIGHT
LT BEM_TOR
£ ASM_FRONT
------ 2 ASM_DEF_CSYS
Lo o Insert Here

first

 Right Click on the Skeleton

and open it
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EXERCISE - Top-Down Design Tools

Create default datums

DER £l p il
.
[ J C I I Ck Create Fle Edt View Insert Anslysis Infa Appications

‘*f-?l%fnl ¥ - Ergaals®oR 8 U
datum plane icon T[%]'ﬁl e Oéain | reniaton] Properiee}
References
to create default : TM1.F1DATUM PLANE]  On \|~
s N DTMZF2DATUM PLAME) On
DTM3:FIDATUM PLAME) On
datums —
Offzet twpe =TT
 Click create | y o
coordinate system , P M+ 000
M = [o.oo
e Select DTM1,
DTMZ, DTM 3 in | oK J[ Cancel ]
order as [ 2
references L o |




EXERCISE - Top-Down Design Tools

Create a sketch to scale skeleton

» Create a Sketch " EE8AG eo ) e BN

SIFIREAER L

e Select DTM3 as e

| T GRINDER_SKEL.PRT

Front o

» Sketch a “T” as shown

e 6H X 3.56W

& \When constraint is displayed: Right click ta disable it. Press Shift + right click ta lock ik, Use Tab key to toggle active constraint

* S 200 /|7

i

= RO B N

% 4




EXERCISE - Top-Down Design Tools

Create layout datums

& GRINDER_SKEL (Active) - Pro/ENGINEER Education Edition ATUM AXIS
Elle Edit ¥iew Insert Analysis Info  Appl

Tools  Window

= = T S T e s el

e Create an Axis normal to e

DTM3 and offset 4.5in Flalslal
GRIMDER _SKEL.FRT

from DTM2 5

References

DTMZFIDATUM FL... Mommal

Offset references

£7DTM3
i Q{ucso
;:";f::;:?H‘e,e DTHM1:FI[DATUM PL.. 0.00
. " " DTMZF2DATUM PL.. 450
e Rename axis as “CAP

2 selected Al oy || ’é




EXERCISE - Top-Down Design Tools

Create layout datums (cont.)

B DATUM AXIS

B GRINDER_SKEL (Active) - Pro/ENGINEER Education Edition
Elle Edit Yiew Insert Analysis Info  Applications

« Create an Axis normal to DEB&QR [0k RE

L

DTM2 and offset .75in BooEl

Show = |[ Seltings

from DTM1

L7 pmaz
7 B
a0

e Rename axis as

‘MOTOR”

Tools

References

DTMZFDATUM PL...  Mormal

Offset references

DTMIFIDATUM PL... 0.00
DTMT:FIDATUM PL... 0.75

@1

LT A




EXERCISE — Top-Down Design Tools

Create layout datums (cont.)

» Repeat the process twice DEE&0 G ne s hRREACT]

Ele Edit View Insert @nalysis

GIMEER Ed
Info  Applications  Tools  Window Help

more to locate two AA batteries |+ = &l

o HER

* Normal to DTM2, offset | Z&

7 Sketch 1
Ao

from DTM1 & DTM3
1.5in and .58in,

respectfully

» Rename axes BATT1 and
BATT2

[T GRIMDER_SKEL.PRT

DTM1:F1DATUM PL.. 1.50

OTMZFA0ATUM L. (IR ~

DRSS BTE NI K

2 F ||
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EXERCISE - Top-Down Design Tools

Create layout datums (cont.)

B GRINDER_SKEL (Active) - Pro/ENGINEER Education Edition
Elle Edit Yiew Insert Analysis Info  Applications

Tools
INEE&0 L oo d Bl

» Create a datum plane W

8 Select up to 3 references, such as

. HEEE
through CAP axis and at a o) ]

GRIMDER _SKEL.PRT
L L7 DML

-10deg angle to DTM2 b

L Sketch 1

References
CAP:FRDATUM &xI5] Through
DTMZF2DATUM PL... Offzet

plane, surfacs, sdge or paint to place plane,

L MoTOR
!

 Rename plane e
“CAP_PLANE”

Offzet

R atation

Sl 0




EXERCISE — Top-Down Design Tools

Create layout datums (cont.)

NEE&GQ iveleRRrn | BHFRAEds 'R0 o (>

L2 DTMZF2(DATUM FL... DOffset

» Create a datum plane
offset .375 from DTM2

lane, surface, B‘an‘or:pomt to place plane,

Offset

Translation

[T} GRIMDER _SKEL.PRT
7 DTML

7

* Rename plane 5
“BATT_COVER” i

K
L7 CAP_PLANE
“ o Insert Here

. £7 ¥ Datum Plane id 50

I R RN

Tekated  w v
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EXERCISE - Top-Down Design Tools

@ GRINDER_SKEL (Active) - Pro/ENGINEER Education

File Edit “ew Insert Analvsis Info  Applications Toaols 4

« Model Tree for Skeleton Debayd oo 56
should look like this when ® GRIMDER_SKEL has been saved,

o M= 1 = |
done 2" %""éﬁ|

[ Shgw"’][ Settings"]

(T GRIMNDER_SKEL.PRT

by

----- s BATTZ
----- £F CAP_PLANE
----- £ 7 BATT_COVER
----- B Inserk Here




EXERCISE — Top-Down Design Tools

Create an Industrial Design model

& GRINDER_ID (Active) - Pro/ENGINEER Education Edition

* File > New Part >

“grinder_ID.prt”

e Insert > Shared Data >

Copy Geometry...

e Turn off “Published

geometry only”

 Select grinder_skel.prt

as reference part

» OK for Default CSYS

5 Tools ‘Awindow Help

BeEiEn - BArgeaal@stasl ool gl e

e select or open| o Pl

B E R

[— 97 Extrude
Shon T o _evove

ra e
[J GRINDER_ID. =

L7 RIGHT Dlen

L7 TOP 57 Swept Blend...

L £F FRONT Helical Swesp
JePRT_C5v9 42 Boundary Blend. ..
@ Insert Hel

51 Yariable Section Sweep...

Model Batum 3

annotations 3
Cosmetic

(2 Style...
Restyle. ..

nserts copled geometry

S

it

Yy B K %=
4

ARIGHT

L2

E @@=

Smart = | s
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EXERCISE - Top-Down Design Tools

Create an Industrial Design model e

Optionz  Properties

Bo || Ref Model
[n]

* In Copy geometry...
dashboard, click in

References selection

» Select the CAP_PLANE
and BATT_COVER datum

plane

s

Sho

(o
)
&

FAL S dniniy

GRIMDER_SKEL.PRT o
- E [k
Surface Sets
Click. here ta add item
Chain
Click. here ta add item
Heferences

CAFP_PLAME:FT0[DATUM FLAME]

BATT_COVER:F11{DATUM PLANE

\

Annotationg

0 itemz zelected

EEx
AR EAR N

Il Fow [v] X




EXERCISE - Top-Down Design Tools

Create an Industrial Design model

& GRINDER_ID (Active) - Pro/ENGINEER Education Edition
 Extrude an Ellipse from the nEa8aa] ® B E w0 [ BENFRABsEER| 00 o0 (&l
R EEH G g W
TOP datum plane /1%
. . Shai = Seftings i | ,\ i
o Ry:1.53, RX:1.78, 6|n H "3GDR“;EI’§fﬁID-PRT i O
L7 TOP O -
. -%EE?_NCTSYS_DEF ™
: 4% Extern Copy Geomid 39 '.. -
* Choose Capped ends under |-z ~
. o -
Options -
N ~
Placement Ophons!  Properties 5‘.‘-‘
[u] _
g % EI Depth N .........
| Show~ || Seti  Side1 |k Blind v |[6.00 v -

Side 2
("] GRINDER_ID.FRT e MNone v

£7 RIGHT 0
FS7TOP Capped ends -
E FROMT Al 3




EXERCISE - Top-Down Design Tools

Create an Industrial Design model

& GRINDER_ID (Active) - Pro/ENGINEER Education Edition EEX

Ele Edit Vew [nsert Analysis Info Applications Tooks Window Help

» Sketch a straight curve aligned |ccoea. oo s wm - @rsac@s oW 6900 Lkl e

g Select two entities of vertices to align.
g Select two entities or vertices to align.

1 AwWARNING: layer display status was not saved,
with CAP PLANE datum e
B EEE

Sh!

ow = ][ Seltings ~ |

|

[l

N2

|| GRINDER_ID.PRT

» Sketch a straight curve aligned | 7

£F FRONT
-2« PRT_CSY5_DEF
45 Extern Copy Geom id 39

with BATT_COVER

x ~
2 N
‘

o B
& Insert Here

0,01 % B K

{1}

(&

DAPERigol T

=
=

2edeced [smet | 8




EXERCISE - Top-Down Design Tools

Create an Industrial Design model

@ GRINDER_ID (Active) - Pro/ENGINEER Education Edition
File Edit Wiew Insett Sketch Analysis Info  Applications Tools Window Help

» Sketch latch spine

‘.

(1 GRINDER _ID.PRT
£7 RIGHT
L7 TOP
© L7 FRONT
% PRT_CSYS_DEF
b Extern Copy Geom id 39

#-0p) Extrude 1

&l

7 Project 1
e Project 2
# Insert Here
o) HExtrude 2
7 "Round 1
L) "Round 2

o=@/ 00- 7

3

Nl

RO

;><<




EXERCISE — Top-Down Design Tools

Create an Industrial Design model

& GRINDER_ID (Active) - Pro/ENGINEER Education Edition

» Merge surfaces together

File Edit ¥iew Insert Analysis Info Applications  Toal

indow  Help

I DEE&GRioayRREREN - BHFaaQs ek 86 90k [(glaumE e

AEIE]

Show ™ Settings

(;D g Select quilts to merge.
A
Figferences  Options  Properties

(7] GRINDER_ID.PRT
£ F RIGHT
L LFTOR
L7 FRONT

L% PRT_CS¥S_DEF
Extern Copy Geom id 39
ide 1

& 7 Extrude 2
=
L (lEMerge 1

<5

N s [v] X

DR S Ui B P E = LB

ALt
=

G

2 selected Quit "MH &
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EXERCISE — Top-Down Design Tools

Create an Industrial Design model

GRINDER_IDY (Active)

Fle Edt Wiew Insert Analysis Info  Applications Tools ‘window Help

e Add R.250 radius NZEDage ool BREEM - BHFaalstsh 68800

IREME ;
£ I‘Q)‘i?(;%} L1
g Select an edge with CTRL key pressed to add to this set, or create a new set by selecting an edge or a surface. =
&WARNING: layer display status was not saved.
® GRINDER_ID has been saved, )
& Select items such as Dimensions, Sections, Trajectories, Tolerances, Sutface Finish or ather Features for editing

Show ~ | Settings ~ ]

(] GRINDER _ID.FRT
L7 RIGHT
L7 TOP
L7 FRONT
% PRT_C5Y5_DEF
g Extern Copy Geom id 39
) Extrude L
) Extrude 2
I Merge 1
- sketch 1
Sketch 2

P Round 2
") Round 3
7 Round 4
- & Insert Here

BCB — Mar. 20, 2012 EN1740, S2012



EXERCISE - Top-Down Design Tools

Create an Industrial Design model

& GRINDER_ID (Active) - Pro/ENGINEER Education Edition

File Edit Wiew Insert Analysis Info Applications Tools ‘window Help

iNEEag L oo f B

» All other radii R.060

ANWARNING: layer display status was not saved.
* GRINDER _ID has been saved.

o Select items such as Dimensions, Sections, Trajectoriss, Tolerances, Surface Finish or ather Features for editing

EEEE) /

Show ~ J[ Settings ~ ]

153

(] GRINDER _ID.FRT

{7 RIGHT

L7 TOP

| £F FRONT

; % PRT_C5Y5_DEF

* Ik Extern Copy Geom id 39
B ) Extrude 1

@ o7 Extrude 2

i @ Merge 1

: & Insert Here

I 3 selected




EXERCISE - Top-Down Design Tools

Create an Industrial Design model

& GRINDER_ID (Active) - Pro/ENGINEER Education Edition

* Project sketched curves

onto surface
e Select curve
e Edit > Projected

 Select all intersected

surfaces

y
o

File Edit Wiew Insert Analysis Info  Applications Help

DR &0 R oo

3 (e g5 W

-EFFRaams rem e oo o)falLT e

® Regeneration completed successfully.

AREE

(7] GRINDER_ID.PRT
L F RIGHT
L LFTOR
7 FRONT
% PRT_CSYS_DEF
by Extern Copy Geom id 39
# 5] Extrude 1
& ) Extrude 2
ot I Merge 1
-~} Round 1
7} Round 7
© P Round 3
T Raund 4

F7(EXTRUDE_2)

Select a set of surfaces to project the cury

# Regenerating GRIMDER_ID Feature 14 ot of 14 ...

onta.

£y BATT_COF
A /" /e

—— 7
F7(EXTRUDE2)

=

&

s
T

1 selected

E &1 B

Smart % &

£
‘
o
~
s
wx
3\{ x
o
LGl
F
=
=

DAL SR S BP

|3

v




EXERCISE — Top-Down Design Tools

Create an Industrial Design model

& GRINDER_ID (Active) - Pro/ENGINEER Education Edition

Ele Edt W¥ew Insert Analysis Info  Applications Tools Mindow Help

» Repeat for bottom curve

D2EaaR v hEhiEn - BHgaalsdtashl 8000z ix% e

o
® GRINDER_ID has been saved,

REE]
Shaw ¥ [Tr\gs'}

() GRINDER _ID.PRT
«£F RIGHT
L7 TOP
-£F FRONT
% PRT_C5Y5_DEF
g Extern Copy Geam id 39
) Extrude 1
) Extrude 2
s @Merge I
~ 7 Round 1
o

7 Roun
o

S

3

s

DAL HS DI E =D R =R

L
[

R 2

| 1 selected 5m

3
;|
©n
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EXERCISE — Top-Down Design Tools

Create an Industrial Design model

& GRINDER_ID (Active) - Pro/ENGINEER Education Edition

Fle Edt Wiew Insert Analysis Info  Applications Tools ‘window Help

° Cut Surface With Trim D E &G E ooy E%EEEQH;‘-|@?*%5@\G\@&GEE%J@@\gj&uq,;x”;égﬂzk‘?

5l

& Select any plane, curve chain or surface to Use as a trimming object.

|

¥ cumerispral 54 (13 Il B [v] X

Fief Optiore Properties.

 Select surfaces ABDRE

Show ™ ][ Seftings * |

o Ry

{1 GRINDER _ID.PRT
£7 RIGHT

. . -7 TOP
e Edit>Trim L
% PRT_CSYS_DEF
- Mg Extern Copy Geom id 39
) Extrude 1
& Extrude 2

x
= R
.

e Toggle through until | ==

Y 2

y

keep both sides s [:2==

selected

FeRhiggBEe@=

7

=l

Ale

&

&
| Al v | &
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EXERCISE - Top-Down Design Tools

Create an Industrial Design model

& GRINDER_ID (Active) - Pro/ENGINEER Education Edition
File Edit Wiew Insert Analysis Info  Applications

D2 E &0 4 v

Tools  ‘Window Help

e
* The reason for a separate gt B
 Annotations will not be displayed.
* Spin Center will not be displayed.
® GRINDER_ID layer 03___PRT_ALL_CURVES,
# Layer statuses changed successfully. Repaint to see the results,

ID model...most Industrial e

{1 GRINDER _ID.PRT

Designer want to see the

%‘ PRT_C5Y5_DEF
Mg Extern Copy Geom id 39
# ) Extrude 1
# 0 Extrude 2
rerge 1
= Round 1
i Round 2
i Round 3
7 Round 4

whole product while

designing

-y Project 1
* %Pm]ett &
Trim 1

= Insert Here

- ErFAQA@aRsR 86800 gLk N

i3 _

S B %

L

< e

o

T &g




EXERCISE — Top-Down Design Tools

Create an Industrial Design model

& GRINDER_ID (Active) - Pro/ENGINEER Education Edition

Fle Edt Wiew Insert Analysis Info  Applications Tools ‘window Help

* Insert a copy of the base NEE8GRocibREEN [ BrERaBsReRl 68660 &44k%uw

1 Surface Set

surface feature into the tree, | pemm o
A EIE.

References  Options  Properties.

3

n Moo [v] %

Show ~ [ Settings =

just after it’s created. e

| L7 RIGHT

%PR'LCSVSJEF

oy Extern Copy Ggomid 39
& ) Extrude L

- o dnsert Here)

Ly copy 1

B

x
e Y
.

B Dol @ W0 %Nk%

Insern Mede &

| C—
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EXERCISE — Top-Down Design Tools

Create an Industrial Design model

FEX
File Edt Wiew Inset cation ow

DEEHAGGL oot BEEEN - BrFaca@sdashl (@ooo(ziauh v

* Here’'s the ID model 3l

* Model wil be displayed in wireframe display.
ANWARMING: laver display status was not saved.
* GRINDER_ID has been saved,

¥ [ ]

Show ¥ |[ Settings ~ ]

£7

(1 GRINDER_ID.PRT :"
-7 RIGHT

- £F TOP 2l
L7 FRONT

< PRT_CSYS5_DEF
4 Extern Copy Geom id 39

L0 % B

=

=l
/B/
B
S
9
oo
4
o
E?J

==
™

B & e =
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