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1. Fig. 1 shows a square, 4 noded finite element.  The nodes are numbered as shown. The displacements (in 
mm) at the four corner nodes are (0.0,0.0) , ( 1.0,0.0)− , ( 0.5,0.5)− , ( 1.0,1.5)−  (in mm)  By interpolating 
between the nodal values as follows 
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where 
1 2/ , /x B x Hξ η= =  

 write down an expression for the displacement at an arbitrary point  
1 2( , )x x within the element. 

 
Assume that this is a plane strain element, so that 3 0u =  
 
At the center of the element 1 20.5 , 0.5x cm x cm= = , compute 
values for 
 
(i) the components of the displacement gradient tensor;  
(ii) the components of the deformation gradient tensor; 
(iii) the Lagrange strain tensor; 
(iv) the infinitesimal strain tensor; 
(v) compute the principal values of infinitesimal strain, and determine the principal directions of strain. 
 
You can do the calculations efficiently in matlab by setting up matrices to do the interpolation.  For example, 
you could find a matrix N with the property 
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You can then find the displacement gradient matrix, and use the matrix processing capabilities of Matlab to 
compute everything else. 
 
Submit a solution by cutting and pasting a screenshot of your MATLAB and its solutions into a text 
document and creating a pdf that can be combined with the rest of your homework and uploaded to 
CANVAS. 
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Here’s a MATLAB ‘Live Script’ 
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2. ‘Circle Grid Analysis’ is used to estimate strains induced in sheet metal parts during stamping or drawing.  
The figure shows a typical example.   Suppose that the three lengths 1 2 3, ,L L L  on a circle with initial radius 
R are measured.   
 
2.1 Find a formula for the components of the 2D Lagrange strain tensor in terms of the lengths and R.    
 

We use the formula 
2 2

0
2
02

l l
l
−

= ⋅m Em  for the three lines shown and solve. 

 
Here’s a MATLAB solution 

 
 

[3 POINTS] 
 

2.2 Check that you get the correct solution for a rigid rotation (i.e. put in values for 1 2 3, ,L L L  consistent with 
a rigid rotation) 
 
A rigid rotation would mean that 1 2 32 , 2L R L L R= = =  .   For this choice E=0 as expected. 
 

[2 POINTS] 
 



3. The twisted cylinder shown in the figure has a displacement field (in polar coordinates) 

rz
L θ
φ

=u e  

 
where φ  is the angle of twist at the end of the cylinder.  The 
contours show the magnitude of the displacement vector, to help 
visualize the deformation. 
 
Calculate the length of a material fiber that lies on the outer surface 
of the cylinder (r=a) and is parallel to the ze  direction before the 
cylinder is twisted (its best to do the matrix calculations with a 
symbolic manipulation program). 
 
We can do this by using the formula for lengths in terms of Lagrange 
strain tensor.    
 
 
Start by calculating the displacement gradient. We need the cylindrical-polar formulas for the gradient of a 
vector v from Section 3.6 of the notes 
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In the problem here /u rz Lθ φ=  and all the other displacement components are zero.  Therefore 
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The Lagrange strain tensor follows as [( ) ( ) ] / 2T= +∇ +∇ −E I u I u I  .   The length of the fiber then follows 
as 
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4. Consider the 2D infinitesimal strain field 
2 2
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21 1 2 2x x x x r x x
r r r r r

ε ε ε= − = − = − = +  

Show that the strain field is compatible, and find the corresponding displacement field (the integrals you 
need to do to find 1 2,u u  from 11 22,ε ε   look a bit scary - you might be able to see the answer by looking at 
them, but if not Matlab will do them easily) 
 
The compatibility equation is  
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Here’s a MATLAB script to check compatibility 

 
 
To find the displacement we use the conditions 
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We can integrate the first two and substitute into the third 

 

 
This shows that  
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The displacement is therefore 
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5. In this problem you will (i) Investigate further the influence of element choice and mesh design on the 
accuracy of FEA simulations; and (ii) Explore the use of rigid surfaces and tie constraints to apply boundary 
conditions to a solid component and (iii) examine the effects of the NLGEOM parameter. 
 
5.1 Start by generating the box-beam with section illustrated in the figure below in the ‘Part’ module.  Make 
the extrusion 20 units long (units are mm). 
 

 
 
5.2 Next, create a planar ‘Discrete Rigid’ flat planar part with dimensions 1.5x1.5mm and center at the 
origin. 

 
 



5.3 Partition the square plate (use Tools > Partition …., select ‘Face’ and ‘Shortest Distance between points’) 
then select the mid-points of the top and bottom edges of the plate, and select ‘Create Partition’.    You 
should end up with a line down the middle of the plate as shown.  Then select ‘Tools > Reference Point’ and 
select the point at the center of the plate to create a reference point.    Finally, use Tools > Set> Create…, 
enter ‘Refpoint’ to name the set (or any convenient name), select ‘Geometry’ in the selection window then 
select the reference point.    

                 
 
5.4 Assign an isotropic elastic material with Young’s modulus E=210000 (units are MPa) and Poissons ratio 

0.3ν = to the beam. 
 
5.5 Create an instance of both parts in the Assembly module.  You can accept the default positions for both 
parts. 
 
5.6 Create a static step with NLGEOM active and all other parameters set to default values.   
 
5.7 Next, connect the two parts together.  To do this select ‘Constraint > Find Contact Pairs’ then press the 

‘Find Contact Pairs’ button   .     You should see one contact pair listed in the window – if 
you select it in the window below the two parts in contact should be highlighted in the viewport.    

 
To tie the two parts together, change the Interaction’ under the Type column to Tie. 
 
5.8 In the Boundary Condition module, set the u3 component of displacement to zero on the entire end of the 
beam to zero, then set u2 to zero at the bottom edge and  u1 to zero at the left hand edge.  You should end up 
with the boundary conditions shown in the second figure. 

         
 

5.9 You can now load the beam by applying forces and displacements to the reference point on the rigid 
surface part.   The reference point is a special type of node, and so also has rotational degrees of freedom; 
and allows you to prescribe moments.   As a first test, apply a twisting rotation UR3 =0.5 radians to the 
reference point on the rigid surface. 



 
5.10 in the mesh module, seed the beam part with a spacing 0.5mm; and mesh the beam with the default 
element type.   Then seed the flat plate part with the same mesh size, and mesh it with the default elements 
(you need to mesh discrete rigid surfaces.   Analytical rigid surfaces do not need to be meshed). 
 
5.11 Create a job in the usual way, and run the analysis.    
 
5.12 In the visualization module, plot contours of the displacement magnitude.   Zoom into the fixed end of 
the beam (at z=20).   Hand in an image showing the displacement contours and contours of stress near the 
fixed end.   The strange displacement field you see is called ‘hourglassing’ and is because 8 noded reduced 
integration elements have a have a soft deformation mode.  Usually reduced integration elements perform 
better than fully integrated ones, but they can produce strange looking displacements for some types of 
loading where the soft mode is activated. You can fix this in two ways: 

• Go back to the ‘Mesh’ module and assign a new element type to the beam – when you do so, 
uncheck the ‘reduced integration’ option for the 8 noded brick. Then Mesh the part with the new 
elements.  Run the test with this choice 

• Repeat this test with quadratic elements, but re-check the ‘reduced integration’ box.   Quadratic 
reduced integration elements are less susceptible to hourglassing. 

 
5.13 Next, we will test the response of the cantilever under a bending moment.   Set this up as follows: 

• Delete the boundary condition that applies a rotation to the reference point 
• Create a Load that applies a moment of -1000 Nmm about the y axis to the reference point 
• In the ‘Step’ module use Output>History Output Request > Create…  ; in the history definition 

window select ‘Set’ and then for the set select the reference point, and then check the 
Displacement/Velocity/Acceleration box, expand the menu and make sure the Translations and 
Rotations options are checked. 

• Change the mesh type to reduced integration quadratic elements 
• Run the analysis, and use the visualization module to find the U1 displacement of the reference node 

at the end of the analysis.   One way to do this is to (i)   go to Result > History Output, then select 
U1  for the reference point (you named it in part 5.3); then select Save As, and enter a name.  You 
can view the data points by going to Tools> XY Data> Edit.   Compare the FEA prediction with the 
exact large deflection solution for a beam length L (much longer than its cross-sectional 
dimensions), area moment of inertia I and Young’s modulus E much longer than its cross sectional 
dimensions 

1 1 cosexact EI LMu
M EI

 = − 
 

 

• With the same mesh seeding, run analyses to complete the table below. To generate tetrahedral 
elements you will need to use the Mesh> Controls box and check Tet; you will need to use the 
‘Element Type’ menu to select the linear or quadratic tets.  Note the poor performance of linear tets. 
Elements 

1 1 1( ) /FEA exact exacte u u u= −   
Quadratic reduced integration bricks  
Linear (8 noded) (fully integrated) 
bricks 

 

Quadratic (10 noded) tetrahedra  
Linear tetrahedra  
Linear elements, elongated mesh (see 
below) 

 

Linear incompatible mode elements, 
elongated mesh (see below) 

 



• For the next test, return to the Mesh module and delete the part mesh for the beam.   Then, delete the 
Part seeds.    The select Seed > Edges and select the four edges at the end of the beam shown below.  
Seed the edges with a 0.25mm spacing.  The Seed > Edges and select one of the longitudinal edges.  
Seed the edge with a 2mm mesh spacing.  Then select Linear fully integrated 8 noded hexahedral 
elements in Mesh > Element type (make sure Reduced Integration is not checked), and a Hex 
meshing algorithm in Mesh > Controls.   Mesh the part.  You should end up with a part meshed with 
very elongated elements as shown in the figure (this mesh at first sight makes sense, because the 
displacements vary rapidly across the cross-section, but slowly along the beam length).   Calculate 
the end displacement and add the entry to the table above.   You should find that the displacement is 
much too small.   This is caused by a phenomenon called ‘Shear Locking’ – linear hex and quad 
elements  perform very poorly in bending because they can’t interpolate the displacement field 
correctly.   This can be fixed by adding extra degrees of freedom to the element.   Go back to the 
‘Mesh’ module and check the ‘Incompatible Modes’ option in the Element type selection menu, then 
re-mesh the part and repeat the analysis.   In general, it is best to avoid meshing a part with very 
elongated elements – they should be as close to cubes as possible.  But sometimes this is not 
possible, and ‘Incompatible Mode’ elements are the next best choice.   

 

 

 
• Finally, in the last test we will study the influence of the NLGEOM option on the predictions of this 

analysis.   Return to the mesh module, delete the edge seeds and mesh, and re-mesh the beam with 
fully integrated quadratic hex elements with side length 0.25 in all directions.   Then go to the Load 
module, edit the ‘Load’ definition to change the magnitude of the applied moment to increase its 
magnitude by a factor of 10 to -10000 Nmm.   In the step module, double check that the NLGEOM 
option is checked, and then run the analysis.   Look at the ‘Job>Monitor’ option – you will find that 
ABAQUS needs to reduce the increment size to 0.25 sec for the analysis to converge.   Plot the 
deformed mesh – you will see a large deflection, and now four frames appear in the results (one for 
each increment).   Extract the displacement at the end, and fill out the entry in the table below.  Then 
repeat the analysis with NLGEOM off (go back to the step module, edit the step, and to deactivate 
the NLGEOM option press the small pencil icon next to NLGEOM then uncheck the box in the 
menu.   Notice that (i) with NLGEOM off, the solution completes in a single increment – that is 
because the approximate equations are linear.   Secondly, the analysis predicts a displacement that 



agrees with the linear beam bending formula 1
approxu  below, which you might recognize from 

ENGN310 as the classical beam theory solution to a cantilever loaded by a moment at its end (it is 
also the leading nonzero term in the Taylor expansion of the exact solution). 

2
1 11 cos

2
approxexact EI LM MLu u

M EI EI
 = − = 
 

 

Elements 
1 1 1( ) /FEA exact exacte u u u= −   *

1 1 1( ) /approx approxFEAe u u u= −  
NLGEOM on   
NLGEOM off   
 
 
As a solution to this problem please submit: 
1. An image showing hourglassing (include this with your pdf or word solution) 
2. Your completed tables 
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