
EN1750: Advanced Mechanics of Solids 
 

Homework 5: Static solutions for elastic solids.  
 

Due Friday Oct 26, 2018                          
School of Engineering 
    Brown University 
 
 
1. A solid cylindrical bar with radius a and length L is subjected to a uniform 
pressure p  on its ends.  The bar is made from a linear elastic solid with 
Young’s modulus E  and Poisson’s ratio ν . 

1.1 Write down an equation for the stress in the bar.  Show that the stress 
satisfies the equation of static equilibrium, and the boundary conditions 

ij i jn tσ =  on all its surfaces.  Express your answer as components in a 

Cartesian basis 1 2 3{ , , }e e e  with 1e  parallel to the axis of the cylinder. 
 
This is a trivial problem – the bar is in a state of uniaxial tension 11 pσ = −   
with all other components zero. 
 
The side face has a normal vector 2 2 3 3( / ) ( / )x a x a= +n e e  and so ⋅ =n σ 0  , while on the end faces the 
normal vector is parallel to 1e  so p⋅ = −n σ   
 

[1 POINT] 
 
1.2 Find the strain in the bar (neglect temperature changes) 

 
The elastic stress-strain relations give 11 22 33/ /p E Eε ε ε ν= − = =  ; all other components zero. 

 
 

[1 POINTS] 
 

1.3 Find the displacement field in the bar  
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[1 POINT] 

 
 
1.4 Calculate a formula for the change in length of the bar 
 



1( ) /L u L pL E∆ = = −   
[1 POINT] 

 
1.5 Find a formula for the stiffness of the bar (stiffness = force/extension) 
 
The force is 2

1p ap− e  ; therefore 2/ ( )k L E ap=   
 

[1 POINT] 
 
 
1.6 Find the change in volume of the bar 
 
This can be done in many different ways – the volumetric strain is 11 22 33 (1 2 ) /p Eε ε ε ν+ + = − −  ; this 

is the fractional change in volume.   So the change in volume is 2 (1 2 ) /V a L p Ep ν∆ = − −  

Alternatively the original volume is 2a Lp  ,  
the deformed volume is [ ] [ ]2 2(1 / ) 1 / (1 (1 2 ) / )a p E L p E a L p Ep ν p ν+ − ≈ − −  , and we get the same 
result. 
 

[1 POINT] 
 
 
1.7 Calculate the total strain energy in the bar. 

 

The strain energy density is 21 / 2
2 ij ij p Eσ ε =  so the total strain energy is 

2 2 / 2W a Lp Ep=  
[1 POINT] 

 
 

 
2. A specimen of material is placed inside a rigid box that prevents the material from stretching in any 
direction.   This means that the strains in the specimen are zero.  The specimen is then heated to increase its 
temperature by T∆ .  Find a formula for the stress in the specimen.  Find a formula for the strain energy 
density.  How much strain energy would be stored in a 31cm  sample of steel if its temperature were 
increased by 100C?  Compare the strain energy with the heat required to change the temperature by 100C – 
the specific heat capacity of steel is about 470 J/(kg-C) 
 
The elastic stress-strain equations are 
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The strains are all zero, so 

11 22 33 1 2
E Tασ σ σ

ν
∆

= = = −
−

 

The strain energy density is 21 3 ( )
2 2 1 2

e
ij ij

E Tσ ε α
ν

= ∆
−

  

 
Steel has a Youngs modulus of about 210GPa, thermal expansion coefficient about 15x10-6K-1 and Poissons 
ratio about 0.3.   So this gives 1.778 MJ/m3.   So a 1cm3 sample has 1.77Joules of strain energy…. 
 
The mass of a 1 cm3 sample is 0.0081kg; the energy required to heat this by 100C is 378J. 
 

[4 POINTS] 
 
 
3. Amber Kinetics offers a flywheel energy storage system.   The goal of this problem is to work through 
some rough design calculations for their device. 
 
Idealize the flywheel as a hollow cylinder with mass density ρ   that 
spins at constant angular speed ω  .  The rotational accelerations will 
induce a stress field in the cylinder.   Work through the following steps 
to calculate this stress field 
 
3.1 Assume that the displacement field in the cylinder has the form 

( ) r zz zu r zε= +u e e  ( ( )u r  is a function to be determined, and zzε  is a 
constant axial strain to be found).    Find a formula for the infinitesimal 
strain in the cylinder in terms of u  and its derivatives and zzε  .  Use 
cylindrical polar coordinates. 
 

We have that { }1 ( )
2

T= ∇ + ∇ε u u .  We can use the formula for 

cylindrical-polar gradients 
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[1 POINT] 
3.2 Hence, find a formula for the stress in the cylinder, in terms of u(r) and its derivatives and zzε   

The linear elastic stress-strain relations give 
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[1 POINT] 
3.3 Assume that the cylinder is rotating at constant angular speed (with no vibrations or any other kinds of 
motion), and assume the displacement is small, so the acceleration vector is (approximately) 2

rrω= −a e  
(from the circular motion formula).   Hence (using the linear momentum balance equation in polar 
coordinates) show that the displacement u® must satisfy 

( ) ( )( )2
2
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1 1 21 1
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u u u ru r

r r r r r Er r
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ρω
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+ −∂ ∂ ∂ ∂ + − = = − 
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(It is possible to do the algebra by hand but it’s a bit nasty – Matlab or mathematica will do it for you if you 
like). 
 
We need to substitute (3.1) into (3.2) and then substitute the stresses into the EOM in cylindrical polar 
coordinates.   From class, the linear momentum balance equation in cylindrical polar coords is 

 
Only the first equation is nonzero 

21 ( )rr
rr

d r
dr r θθ
σ σ σ ρω+ − = −  

Here’s a MATLAB solution, which can be rearranged by hand into the final form 

 
 

[3 POINTS] 
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3.4 Finally, for boundary conditions assume that 

• The radial displacement at r=a is zero,  
• The radial stress at r=b is zero.    

• The axial force 2
b

z zz
a

F rdrpσ= ∫  is zero. 

Use your favorite symbolic manipulation program to solve the differential equation in 3.3 for the 
displacement field with these boundary conditions and hence find formulas for the stresses (you can 
download and modify the solution for the spherically symmetric problem solved class if you want to use 
Matlab). Simplify your final expression by substituting  a=0 (to produce a solid cylinder)   

 
Solving these equations (even in a symbolic manipulation program) is a bit of a chore.  Your calculation 
could follow these steps: 

(1) Integrate 3.3 with respect to r twice to find a formula for u(r) – the answer will contain two arbitrary 
constants 

(2) Substitute the solution for u from (1) into the formula for zzσ  in terms of u(r) and zzε  
(3) Integrate (2) to find a formula for the axial force (still in terms of u(r). 
(4) Solve the result of (3) and the condition 0zF =   for the unknown axial strain zzε . 
(5) Substitute the result of (4) into the result of (1) to find a formula for rrσ  in terms of u(r)  
(6) Use the results of (5) and (1) and the conditions ( ) 0, ( ) 0rru a bσ= =  to get two equations for the 

two unknown constants of integration 
(7) Solve the equations for the constants, and hence find u(r) 
(8) Substitute the results of (7) , as well as a=0 into the formulas for stress and simplify the results. 

 
 
Hence, plot a graph showing 

(a) The normalized Von-Mises stress 
2 2 2
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(b) The normalized stresses 2 2 2 2 2 2, ,rr zz
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as functions of normalized radial position /r b  in the disk, with Poisson’s ratio 0.3ν =  .  Hand in 
your solutions for the displacement field and stress fields, and the graph 
 



 

 
 

[5 POINTS] 
 
 3.2 Suppose that the material in the disk is made from a metal, so that the device must be designed and 
operated to ensure that the Von-Mises stress eσ  stays below a critical value Y  (the yield stress of the 
metal).   Show that the maximum kinetic energy that can be stored in the disk is  

maxU YVβ=  
where V is the volume of the cylinder and β  is a constant that depends only on Poisson’s ratio.   Find the 
formula for β   



Just in case you don’t remember this from ENGN40 - the kinetic energy in the disk is 21
2 zzI ω   where 

21
2zzI mb=  is its mass moment of inertia about the axis of rotation.      

 
Re-writing the KE in terms of density gives 

2 21
4

U b Vρω=  

  
The preceding problem shows that the maximum Mises stress occurs at r=0 (if you are super-cautious you 
can check that this is still true for all physically admissible values of Poissons ratio), where 
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To avoid yield we must design and operate the device so that 
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[5 POINTS] 
 
 

3.3 Amber Kinetics say their disk is made from steel, and give the following specifications for their device: 
• Weight: 10000lb  
• Dimensions Width 54 inches and height 52 inches.    
• Energy stored: 32 kWhr. 

Steel has a density of 8050kg/m3 

 
Estimate the yield stress of their steel. 
 
Converting 10000lb to kg gives m=4536kg; steel density is 8050kg/m3 

The energy is 115.2 MJ 
 

 
This gives Y=263MPa – this seems like rather a conservative value but the designers may have kept the 
stresses low to ensure a long fatigue life. 
 
 

[3 POINTS] 
 
 
4.  Show that the function 
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is a valid Airy function (i.e. show that it satisfies the biharmonic equation).  You can use Matlab or 
Mathematica if you want.   If you do this please upload a copy of your MATLAB or mathematica script to 
Canvas as part of your HW submission (there is a separate link for this upload) 
 
 
Here’s a MATLAB demo 

 
 
This shows that diff2=0, which means the equation is satisfied. 
 

[2 POINTS] 
 
Next. show that the function generates a stress state that represents the solution to a large plate containing a 
circular hole with radius a at the origin, which is loaded by a tensile stress 0σ  acting parallel to the 1e  
direction.  To do this,  
 
 
 
4.1 Show that the surface of the hole is traction free – i.e. 0rr rθσ σ= =  on r=a 
 
The calculation can be done easily in MATLAB: 

 
 
Substituting r=a shows that the stress does indeed satisfy the boundary conditions. 
 

[3 POINTS] 
 
 
 



 
4.2 Show that the stress at /r a →∞  is 0 (1 cos(2 )) / 2rrσ σ θ= + , 0 (1 cos(2 )) / 2θθσ σ θ= −

0 sin(2 ) / 2rθσ σ θ= − . 
 
Substituting a=0 into the formulas above gives these results…. 
 

[1 POINT] 
 
4.3 Show that the stresses in 4.2 are equivalent to a stress 11 0 22 2, 0σ σ σ σ1= = = .  It is easiest to work 

backwards – start with the stress components in the { }1 2 3, ,e e e  basis and use the basis change formulas to 

find the stresses in the { }, ,r zθe e e  basis 
 
You can do this many different ways – eg use the basis change formulas with the Q matrix.  Here we’ll use 
dyadic notation. 
 
Note that we can write the 1 2{ , }e e  basis vectors as 
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(remember the dyadic product is telling us which part of the matrix each term represents - 1 1⊗e e  is the 11 
term, similarly r r⊗e e  is the rr term in the polar form, and so on).   We can write the answer in matrix form 
as 

2
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And finally 2 2 1cos (1 cos 2 ) / 2 sin (1 cos 2 ) / 2 sin cos sin 2
2

θ θ θ θ θ θ θ= + = − =   

so we get the answer we wanted. 
[3 POINTS] 

 
 
4.4 Plot a graph showing the variation of hoop stress 0/θθσ σ  with θ  at r a=  (the surface of the hole).  
What is the value of the maximum stress, and where does it occur? 
 



 
 
The plot is shown, the max stress occurs at the top and bottom of the hole, and it is 3 times the remote stress 
– so we see the famous factor of 3 for the stress concentration associated with a circular hole in an infinite 
plate…. 
 

[3 POINTS] 
 
 
 
 
 
 
 
 
5. The picture shows a solid cylindrical column with cross-sectional area A and height L.  The column is 
subjected to a gravitational body force 2gρ− e  per unit mass.  
 
Assume a kinematically admissible displacement field of the form 
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5.1 Use Matlab (or whatever symbolic manipulation program you prefer) to 
calculate the potential energy, and then minimize the potential energy with 
respect to 1 2 3 4, , ,λ λ λ λ .  Hence, estimate the strain and stress field in the 
solid.   
 
The potential energy is 

V V

UdV dV− ⋅∫ ∫b u   

 
Where U  is the strain energy density.  For this problem we have the following strain distribution 
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The strain energy density follows as 
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The total potential energy is therefore 
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We then have to minimize wrt each of the 1 2 3 4, , ,λ λ λ λ .   MATLAB gives 

 
 
 
MATLAB code is below 



 
 
 
This is not strictly legal, but you can get a simpler approximation if you ignore the contribution to the strain 
energy density from the shear strains.    

( )22 2 2
11 22 33 11 22 332(1 ) 1 2
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ν ν

 ≈ + + + + + 
+ − 

 

In which case 



 

 
 
This is what you would calculate if you assumed uniaxial stress, and solved the problem by hand.   This 
solution satisfies equilibrium, but the strain distribution is not compatible. 
 
If people used this solution it should get credit too, even though it is not quite right. 
 

[4 POINTS] 
 
5.2 Is the solution obtained in this way exact?  (i.e. does the stress field satisfy equilibrium and boundary 
conditions?) 
 
The solution is not exact, because it doesn’t satisfy the boundary conditions on the sides of the bar, and it 
doesn’t satisfy equibrium exactly either. 
 
The solution does become more and more accurate as the cylinder gets longer compared with its radius, 
however.    
 

[1 POINT] 
 
 
 
 
 



 
 
 
 
 
 
 
6. Orthogonal machining model:  In this problem you will set up a simple 2D model of an orthogonal 
machining process (see the figure).    The problem uses several advanced techniques in FEA: 
(1) Modeling contact  
(2) Modeling material failure, with element deletion 
(3) Using the ‘Arbitrary Lagrangean-Eulerian’ formulation available in ABAQUS to avoid problems caused 
by large distortion of the mesh. 
 
 
The goal is to set up the model shown in the figure: a thin layer of material is removed from a workpiece 
(made from Al) by a rigid cutting tool. 
 
For a unit system we will work with dimensions in mm; forces in N; stresses in MPa, and time in 
milliseconds (note that 1 m/s is 1 mm/millisecond). 
 
6.1 Start by creating parts for both the workpiece and cutting tool.  The workpiece is a 2D deformable part; 
the tool is a discrete rigid part with Wireframe base feature. Relevant dimensions are shown in the figure.  
To make it easier to position the parts in the assembly, place the top right corner of the rectangle representing 
the workpiece at the origin.   You don’t have to get the tool dimensions exactly the same as those shown in 
the figure.    Note that the dimensions are in mm. 
 



         
 
 
For mesh generation and adaptive meshing we will have to partition the workpiece as shown below.   To do 
this, first partition the block down the middle – select the ‘partition by shortest distance between two points’ 

 tool from the toolbar then select the midpoints on the two vertical sides of the workpiece.   Next, 

partition the top half of the block down the middle.   To do this select the ‘Partition face by sketch’  
tool, select the top half of the block in the viewport and press ‘Done’ then sketch a horizontal line down the 
center of the top half of the block.   You should end up with a partitioned part that looks like the picture 
shown below. 
 

     
Finally we need to add a reference point so we can apply boundary conditions to the tool.   Make sure the 
tool is shown in the viewport, then select Tools > Reference point, and select the point midway down the 
back face of the tool (see the figure above). 
 
6.2 In the Property module, create a new material called Al that will be assigned to the workpiece.  This 
publication has material properties for a Johnson-Cook plasticity/damage model for a 5xxx series Al alloy.   
Enter values in MPa  (this is convenient because 1N/mm2 is the same as 1 MPa, so forces will be in 
Newtons) 

• Young’s modulus E = 70 000 MPa 
• Poissons ratio 0.3 
• Density: 2700 kg/m3 – but we have to be careful to enter its value in a consistent set of units.  

Convince yourself that if we choose to use N for force, mm for length, and milliseconds for time, we 
must enter density in  N milliseconds2/mm4, which makes 32.7 10ρ −= ×  in our chosen unit system 

• Plasticity – (select Mechanical>Plastic and use the Johnson-Cook hardening model in the drop-down 
menu.  Then enter values of the parameters that define how the material hardens with strain and 
strain rate: 
A=277.3MPa, B=307.93MPa, n=0.69, m=0, Melting T=0, Transition T=0 (temp is neglected) 
Select Suboptions, then select ‘Rate dependent’ and select the Johnson-Cook suboption.  Enter 
C=0.0032,and Epsilon dot zero = 10-6 (in milliseconds-1) 

http://journals.plos.org/plosone/article?id=10.1371/journal.pone.0181983
http://journals.plos.org/plosone/article?id=10.1371/journal.pone.0181983


• Next, enter parameters that will control how the material begins to fail.  In ABAQUS failure is 
modeled by making the material soften once the strain exceeds a critical value.   To enter the 
parameters select 
Damage – select Mechanical > Damage for ductile metals > Johnson-Cook damage and enter for the 
constants: 

            d11=0.211, d2=3.9, d3= -4.7, d4=d5=0 
Finally, we need to enter a parameter that ABAQUS uses to control how elements are removed from 
the mesh after they fail.   This is really a correction factor used during the simulation rather than a 
material property.  It has two purposes: one is to make sure that the stress is reduced to zero 
gradually after an element fails; the second is to reduce sensitivity to mesh size that occurs in 
softening materials.   
To do this select Suboption > Damage Evolution, and enter 0.01mm for the ‘displacement at failure’ 
(this makes ABAQUS remove an element when the plastic strain multiplied by the element size 
reaches 0.01mm) 

(Read the publication cited or the ABAQUS theory manual for definitions of the constants) 
 
Finally, create a homogeneous plane section with plane strain thickness of 5mm and assign it to the 
workpiece (the block). 
 
6.3 Create an instance of both parts in the Assembly module.   
 
6.4 In the Step module, create and Explicit Dynamic step with duration 17 milliseconds (enter 17 in the 
window, not 0.017, since we are working with millisecond time units).   In the ‘Mass Scaling’ tab, check the 
radio button for ‘Use scaling definitions below’ and use Create… to define ‘mass scaling’ for the step.   The 
purpose mass scaling is to increase the stable time-step for the analysis (we will discuss this in more detail 
later in the course).    In the Edit Mass Scaling menu check the ‘Scale By Factor’ box and enter 10000 for the 
mass scaling (this is a rather too large –, but with smaller values you have to wait forever for the job to run). 
 
Secondly, make sure the ‘Status’ variable is saved to the output database (otherwise elements don’t get 
deleted and the deformed mesh looks extremely scary).  To do this select Output > Field Output Requests > 
Manager, then edit F-output-1.  Expand the 
State/Field/User/Time list of variables and 
check the Status box and press OK at the 
bottom of the editor. 
 
Next, use Tools > Set > Create to create a new set called Tool-Refpoint, and select the reference point on the 
tool.  Then use Output> History Output Requests> Create… to create a new History Output request that will 
make ABAQUS save the forces and displacements of the reference point on the tool to the output database 
(select ‘Set’ for the domain, then you can select the Tool-Refpoint set; and check the boxes in the Output 
Variables list). Save the request…. 
 
Finally, the step menu also gives you an option to activate ALE remeshing.  To do this select Other > ALE 
Adaptive Mesh Domain > Manager, and click on Step-1 and select ‘Edit’ in the domain manager.  An Edit 
menu should open: select the ‘Use the ALE adaptive mesh domain below’ radiobutton, then press the arrow 
next to ‘Region’ and select the top rectangle of the part in the viewport.  Accept all the defaults and press 
OK. 
 
 
(Optional – if you want to make a smooth animation of the cutting process you will need to select more 
frequent outputs to the odb than the default – save every 0.5 secs or more frequently) 
 

http://journals.plos.org/plosone/article?id=10.1371/journal.pone.0181983


 
 6.5 In the Interaction module:  (a) create an interaction property with Hard normal contact and Penalty 
tangential contact with friction coefficient 0.1    (b) Create 
an Interaction (Interaction > Create, select Surface to 
Surface Contact (Explicit), then below the viewport select 
‘by angle’ in the dropdown menu, and click on the fillet 
radius of the tool.   The front face of the tool should be 
highlighted in the viewport.   Select the color 
corresponding to the arrow on the outer side of the tool in 
the menu below the viewport.   Then for the second surface 
select ‘Node region’ and select the rectangle at the top of 
the workpiece.   The interaction should be highlighted as 
shown.  Accept the default options in the interaction definition menu. 
  
6.6 For boundary conditions: (1) Prescribe zero vertical displacement on the bottom of the block; (2) 
Prescribe zero horizontal displacement on the left edge of the bottom two partitions of the block; (3) Create a 
‘velocity/angular velocity’ boundary condition for the reference point with a horizontal velocity of -0.25 
mm/ms and zero vertical and angular velocity. 
 
6.7 For meshing, use Mesh> Element Type… to assign Explicit Plane Strain elements – check that the 
‘Element Deletion’ option has the ‘yes’ radio button checked -  to the workpiece, then create a mesh like 
the one below (you can create it by seeding the various horizontal edges with different mesh densities.  In the 
figure shown the top part has a uniform mesh size of 0.02mm).    Seed the tool with a mesh size 0.02mm and 
mesh it. 

 
 
 
6.8 Create a job and run it – it will take some time to complete – you can use Job> Monitor to track its 
progress. 
 
 
As a solution to this problem create a plot of the horizontal force acting on the tool as a function of time. 
 

[10 POINTS] 
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