
EN1750: Advanced Mechanics of Solids 
 

Homework 3: Describing Deformations.  
 

Due Friday Oct 4, 2019                          
School of Engineering 
    Brown University 
 
 
 
1. The (2D) displacement field near the tip of a crack in a large elastic 
solid is 
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where  0.3ν =  is the Poisson’s ratio of the material and A is a constant 
that is proportional to the stress applied to the solid and inversely 
proportional to its shear modulus. 
 
Use MATLAB (eg with a ‘Live Script’) to find the strain distribution, 
and plot contours of the maximum principal strain near the crack tip (for A=1) over the region 

1 21 1 0.1 2.1x x− < < < <   (you only need to submit your plot, not the Live Script) 
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2. Digital Image Correlation (DIC) is a non-contact method for measuring the displacement field on the 
surface of a component or specimen.   The approach is illustrated in the figure: a speckle pattern is painted 
on the surface of interest, and a picture is taken of the pattern before and after deformation.    Image 
processing algorithms can find similar sub-regions of speckles in the two images before and after 
deformation and so determine their motion.    The goal of this problem is to test MATLAB’s image 
correlation functions. 
 
Write a MATLAB script that will perform the following calculations: 
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2.1 Construct a computer generated speckle pattern representing the undeformed specimen.   Recall that in 
MATLAB a matrix can be used to store a grayscale image, eg try 

ref_im = randi(100,701,701)/100; 
imshow(ref_im) 

The value of the matrix ref_im(I,j) stores the intensity of the pixel at row I and column j, with 0 representing 
black and 1 representing white.  Rows are measured downwards from the top left corner of the image; 
colums are counted to the right of the top left corner. 
 
2.2 As a simple test, use the MATLAB ‘imwarp’ function (see the MATLAB manual for details) to translate 
the image by 10 pixels to the right, and 10 pixels vertically upwards.  Imwarp offers several different 
methods for specifying the deformation that will be applied to the image – they will all work for a simple 
translation, but in subsequent problems below it will be necessary to specify the displacement applied to 
every pixel in the image, so this will be your best choice for this problem.  Use ‘imshow’ to check that the 
translated image is correct – the sign convention used by 
imwarp is a bit strange. 
 
2.3 Use the basic matlab DIC code provided on the course 
website to calculate the displacements at a grid of points on 
the image (use a 701x701 pixel image as above; and make 
the physical size of the image 701x701 units.   Compute 
displacements on a grid of points spaced about 50 pixels 
apart and use a template size of 20 pixels – see the fig).  
Plot a contour map of the displacements calculated by the 
DIC algorithm at the grid points to check the results. 
 
2.4 Generate a deformed image corresponding to: 
(i) A constant vertical strain yyε  (of about 5%) with all 
other strain components zero 
(ii) A constant shear strain xyε  (again use about 5% strain) 
with all other strain components zero 
 
Use the DIC code provided to determine the displacements 
from the deformed image, and write a code that will 
calculate the strains from the measured displacements (you 
could use the MATLAB ‘gradient’ function to do this, or 
write your own code).   Plot contours of the two strain 
components. 
 
2.5 As a final test, apply the displacements from problem 1 
to the reference image.  Put the tip of the crack (the origin) 
at the center of the bottom of the image (see the figure).   
Use the DIC code to calculate the displacement field, and 
hence plot contours of the maximum principal strain.       
 
 
Upload your MATLAB script as a solution to this problem. 
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3. The figure shows a material element on the 
surface of a specimen before and after 
deformation.   Calculate the (2D) Lagrange strain 
tensor (as a 2x2 matrix) 
 
 
 
 
 
 
 
 
We can use the length changes of any 3 material fibers to determine the strain – eg OA, OB and AB 
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Solving the equations gives  
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4. Is the strain distribution 
2 3 2 3 3

11 2 22 1 12 1 2/ / /x r x r x x rε ε ε= = = −  
compatible?    If so, please calculate the displacement field (MATLAB will do the integrals).  
 
The equation satisfies the compatibility condition.   Integrating 11 22,ε ε   MATLAB gives 

1 2
1 2 2 1( ) ( )x xu f x u g x

r r
= + = +  

Substituting into 12ε  gives 1 2 1 2'( ) '( ) 0g x f x g A Bx f C Bx+ = ⇒ = − = +  ; A,B,C are arbitrary 
constants representing a rigid motion.   We can take them to be zero…. 
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5. In this problem you will (i) Investigate further the influence of element choice and mesh design on the 
accuracy of FEA simulations; and (ii) Explore the use of rigid surfaces and tie constraints to apply boundary 
conditions to a solid component and (iii) examine the effects of the NLGEOM parameter. 
 
5.1 Start by generating the box-beam with section illustrated in the figure below in the ‘Part’ module.  Make 
the extrusion 20 units long (units are mm). 
 

 
 
5.2 Next, create a planar ‘Discrete Rigid’ flat planar part with dimensions 1.5x1.5mm and center at the 
origin. 

 
 
5.3 Partition the square plate (use Tools > Partition …., select ‘Face’ and ‘Shortest Distance between points’) 
then select the mid-points of the top and bottom edges of the plate, and select ‘Create Partition’.    You 
should end up with a line down the middle of the plate as shown.  Then select ‘Tools > Reference Point’ and 
select the point at the center of the plate to create a reference point.    Finally, use Tools > Set> Create…, 
enter ‘Refpoint’ to name the set (or any convenient name), select ‘Geometry’ in the selection window then 
select the reference point.    



                 
 
5.4 Assign an isotropic elastic material with Young’s modulus E=210000 (units are MPa) and Poissons ratio 

0.3ν = to the beam. 
 
5.5 Create an instance of both parts in the Assembly module.  You can accept the default positions for both 
parts. 
 
5.6 Create a static step with NLGEOM active and all other parameters set to default values.   
 
5.7 Next, connect the two parts together.  To do this select ‘Constraint > Find Contact Pairs’ then press the 

‘Find Contact Pairs’ button   .     You should see one contact pair listed in the window – if 
you select it in the window below the two parts in contact should be highlighted in the viewport.    

 
To tie the two parts together, change the Interaction’ under the Type column to Tie. 
 
5.8 In the Boundary Condition module, set the u3 component of displacement to zero on the entire end of the 
beam to zero, then set u2 to zero at the bottom edge and  u1 to zero at the left hand edge.  You should end up 
with the boundary conditions shown in the second figure. 

         
 

5.9 You can now load the beam by applying forces and displacements to the reference point on the rigid 
surface part.   The reference point is a special type of node, and so also has rotational degrees of freedom; 
and allows you to prescribe moments.   As a first test, apply a twisting rotation UR3 =0.5 radians to the 
reference point on the rigid surface. 
 
5.10 in the mesh module, seed the beam part with a spacing 0.5mm; and mesh the beam with the default 
element type.   Then seed the flat plate part with the same mesh size, and mesh it with the default elements 
(you need to mesh discrete rigid surfaces.   Analytical rigid surfaces do not need to be meshed). 
 
5.11 Create a job in the usual way, and run the analysis.    



 
5.12 In the visualization module, plot contours of the displacement magnitude.   Zoom into the fixed end of 
the beam (at z=20).   Hand in an image showing the displacement contours and contours of stress near the 
fixed end.   The strange displacement field you see is called ‘hourglassing’ and is because 8 noded reduced 
integration elements have a have a soft deformation mode.  Usually reduced integration elements perform 
better than fully integrated ones, but they can produce strange looking displacements for some types of 
loading where the soft mode is activated. You can fix this in two ways: 

• Go back to the ‘Mesh’ module and assign a new element type to the beam – when you do so, 
uncheck the ‘reduced integration’ option for the 8 noded brick. Then Mesh the part with the new 
elements.  Run the test with this choice 

• Repeat this test with quadratic elements, but re-check the ‘reduced integration’ box.   Quadratic 
reduced integration elements are less susceptible to hourglassing. 

 
5.13 Next, we will test the response of the cantilever under a bending moment.   Set this up as follows: 

• Delete the boundary condition that applies a rotation to the reference point 
• Create a Load that applies a moment of -1000 Nmm about the y axis to the reference point 
• In the ‘Step’ module use Output>History Output Request > Create…  ; in the history definition 

window select ‘Set’ and then for the set select the reference point, and then check the 
Displacement/Velocity/Acceleration box, expand the menu and make sure the Translations and 
Rotations options are checked. 

• Change the mesh type to reduced integration quadratic elements 
• Run the analysis, and use the visualization module to find the U1 displacement of the reference node 

at the end of the analysis.   One way to do this is to (i)   go to Result > History Output, then select 
U1  for the reference point (you named it in part 5.3); then select Save As, and enter a name.  You 
can view the data points by going to Tools> XY Data> Edit.   Compare the FEA prediction with the 
exact large deflection solution for a beam length L (much longer than its cross-sectional 
dimensions), area moment of inertia I and Young’s modulus E much longer than its cross sectional 
dimensions 
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• With the same mesh seeding, run analyses to complete the table below. To generate tetrahedral 
elements you will need to use the Mesh> Controls box and check Tet; you will need to use the 
‘Element Type’ menu to select the linear or quadratic tets.  Note the poor performance of linear tets. 
Elements 

1 1 1( ) /FEA exact exacte u u u= −   
Quadratic reduced integration bricks  
Linear (8 noded) (fully integrated) 
bricks 

 

Quadratic (10 noded) tetrahedra  
Linear tetrahedra  
Linear elements, elongated mesh (see 
below) 

 

Linear incompatible mode elements, 
elongated mesh (see below) 

 

• For the next test, return to the Mesh module and delete the part mesh for the beam.   Then, delete the 
Part seeds.    The select Seed > Edges and select the four edges at the end of the beam shown below.  
Seed the edges with a 0.25mm spacing.  The Seed > Edges and select one of the longitudinal edges.  
Seed the edge with a 2mm mesh spacing.  Then select Linear fully integrated 8 noded hexahedral 
elements in Mesh > Element type (make sure Reduced Integration is not checked), and a Hex 
meshing algorithm in Mesh > Controls.   Mesh the part.  You should end up with a part meshed with 



very elongated elements as shown in the figure (this mesh at first sight makes sense, because the 
displacements vary rapidly across the cross-section, but slowly along the beam length).   Calculate 
the end displacement and add the entry to the table above.   You should find that the displacement is 
much too small.   This is caused by a phenomenon called ‘Shear Locking’ – linear hex and quad 
elements  perform very poorly in bending because they can’t interpolate the displacement field 
correctly.   This can be fixed by adding extra degrees of freedom to the element.   Go back to the 
‘Mesh’ module and check the ‘Incompatible Modes’ option in the Element type selection menu, then 
re-mesh the part and repeat the analysis.   In general, it is best to avoid meshing a part with very 
elongated elements – they should be as close to cubes as possible.  But sometimes this is not 
possible, and ‘Incompatible Mode’ elements are the next best choice.   

 

 

 
• In this test we will study the influence of the NLGEOM option on the predictions of this analysis.   

Return to the mesh module, delete the edge seeds and mesh, and re-mesh the beam with fully 
integrated quadratic hex elements with side length 0.25 in all directions.   Then go to the Load 
module, edit the ‘Load’ definition to change the magnitude of the applied moment to increase its 
magnitude by a factor of 10 to -10000 Nmm.   In the step module, double check that the NLGEOM 
option is checked, and then run the analysis.   Look at the ‘Job>Monitor’ option – you will find that 
ABAQUS needs to reduce the increment size to 0.25 sec for the analysis to converge.   Plot the 
deformed mesh – you will see a large deflection, and now four frames appear in the results (one for 
each increment).   Extract the displacement at the end, and fill out the entry in the table below.  Then 
repeat the analysis with NLGEOM off (go back to the step module, edit the step, and to deactivate 
the NLGEOM option press the small pencil icon next to NLGEOM then uncheck the box in the 
menu.   Notice that (i) with NLGEOM off, the solution completes in a single increment – that is 
because the approximate equations are linear.   Secondly, the analysis predicts a displacement that 
agrees with the linear beam bending formula 1

approxu  below, which you might recognize from 
ENGN310 as the classical beam theory solution to a cantilever loaded by a moment at its end (it is 
also the leading nonzero term in the Taylor expansion of the exact solution). 
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Elements 
1 1 1( ) /FEA exact exacte u u u= −   *

1 1 1( ) /approx approxFEAe u u u= −  
NLGEOM on   
NLGEOM off   
 
 

• Finally in this last test we will illustrate the dangers of 
using a mesh that is too coarse. 

 
First, use the model tree to locate the sketch for the cross-
section of the beam (see the figure).  Right click the 
Section Sketch and select Edit… 
 
Then delete the hole at the center of the beam. 
 
Exit the sketch, and use Feature > Regenerate  to regenerate the part.   Ignore the warning about the 
mesh 
 
In the Step module, edit the step, and turn NLGEOM off 
 
Next, in the Load Module use Load> Manager Edit to change magnitude of the moment applied to 
the end of the beam to 1000Nmm. 
 
Now use the Mesh Module to seed the beam with a mesh size of 2 units.  Use Mesh> Element Type; 
select the beam and check the ‘reduced integration’ box is checked.  Then press OK.   Use Mesh> 
Part to mesh the beam. 
 
Return to the Job Module and submit the job.   The analysis should complete successfully (with 
NLGEOM on, the analysis will fail).    
 
Use the Visualization module to check the deformed shape of the beam.   You should see that the 
result is complete garbage. 
 
The reason that this analysis fails is that (i) the mesh is far too coarse; and (ii) reduced integration 
hexahedral elements calculate stresses at the center of each element only(‘reduced integration’ 
means that the strain energy in the elements is calculated at smaller number of integration points 
than is necessary to calculate the energy exactly.   Usually, this is helpful, because meshes consisting 
of arbitrarily shaped fully integrated hexahedral elements tend to be too stiff  .    In the correct 
solution, the stress at the center of a bent beam is always zero – so the bending mode of deformation 
in the beam is spuriously soft.    
 
You can check this by returning to the Mesh Module, and use Mesh> Element Type; select the 
beam and uncheck the ‘reduced integration’ box.   Then run the analysis again and plot the deformed 
mesh.   This time the deformation 
 
As a solution to this problem please submit: 
1. An image showing hourglassing (just paste a screen snip in your pdf solution) 
2. Your completed tables 
3. Two images showing the deformed meshes produced by the tests with coarse meshes. 
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