
EN1750: Advanced Mechanics of Solids 

Homework 6: Static solutions for elastic solids. 

Due Friday Oct 25, 2019    
School of Engineering 
    Brown University 

1. A thermal barrier coating is idealized as a linear elastic thin film with
thickness 2h, Young’s modulus E, Poisson’s ratio ν  and thermal
expansion coefficient α .  It is bonded to a substrate (a turbine blade,
eg) with dimensions much greater than the film thickness, and elastic
properties , ,s s sE ν α  .  The film and substrate are stress free at some 
initial temperature.  The top surface of the film is then exposed to 
combustion gases at temperature 1T  (above the initial temperature), 
while the substrate is kept at a lower temperature 0T  (again, above the initial temperature).  The steady-state 
temperature distribution in the film is 

3 1 3 0 3( ) (1 / ) / 2 (1 / ) / 2T x T x h T x h= + + −  
The substrate remains stress free far away from the film. 

1.1 Write down the boundary conditions for the stress state at the film surface, and the boundary conditions 
for displacement and stress at the interface between film and substrate.  Use the displacement boundary 
conditions to show that 11 11 22 22

film substrate film substrateε ε ε ε= =  at the film/substrate interface 

1.2 Assume that the substrate is stress free, and the stresses in the film vary only in the 3x  direction.   Find 
the stress and strain distribution in the film – show that your solution satisfies: 
(1) The equilibrium equations for stress; (2) the stress-strain-temperature relations; (3) the strain

equations of compatibility. Find a formula for the strain energy per unit area of the film.
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2. The figure shows a cross-section 
through a joint connecting two hollow 
cylindrical shafts.   The joint is a hollow 
cylinder with external radius b and 
internal radius a.  It is bonded to the 
two rigid shafts AB and CD.  Shaft AB 
is fixed (no translation or rotation), and 
an axial displacement 0 zU=u e  is 
applied to the hollow cylinder CD.   
 
The goal of this problem is to estimate 
the axial force necessary to produce displace the shaft CD, and hence determine the stiffness of the 
joint. 
 
 
 
2.1 Assume that the displacement field in the joint can be approximated by ( ) zu r=u e  , where ( )u r  
is a function to be determined.   Calculate the infinitesimal strain tensor in the joint in terms of ( )u r  
and its derivatives (you might remember doing this problem before!) 
 
 
2.2 Assume that the joint can be idealized as an isotropic, linear elastic material with Youngs modulus E and 
Poisson’s ratio ν  .    Find a formula for the stress in the joint a<r<b, in terms of derivatives of ( )u r  and 
the material properties. 
 

 
 

2.3 Use the equation of static equilibrium∇⋅ =σ 0  to show that ( )u r  must satisfy 
2
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You can use the formula for the divergence of a tensor S in cylindrical-polar coordinates 
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2.4 Write down the boundary conditions for displacements 
and/or stresses on the four external surfaces of the joint (i.e. 
give any known values for displacement components 

, ,r zu u uθ  , or stress , , , , ,rr zz r rz zθθ θ θσ σ σ σ σ σ  ) 
 
 
 
 
 
 
2.5 Find a solution for ( )u r  that satisfies 2.3 and boundary conditions on r=a and r=b.  Does the 
solution satisfy all the boundary conditions in 2.4?   If not, which boundary conditions are not 
satisfied? 
 
5.6 Find a formula for the axial force zF  that must be applied to shaft CD to cause the necessary 
axial displacement 0U  .   Hence, find a formula for the stiffness of the joint. 
 
 
 
 
3.  The goal of this problem is to calculate a 2D 
elasticity solution for a uniformly loaded cantilever 
beam, as shown in the figure.  It is best to do the 
algebra using MATLAB or mathematica.    
 
3.1 Write down the boundary conditions for the 
stresses on the top and bottom faces of the beam    
We will find a solution that satisfies these 
boundary conditions exactly.     
 
 
3.2 Write down the boundary conditions for 
stresses at 1 0x =  .   These will not be satisfied 
exactly, but the solution will satisfy zero resultant force on the boundary. 
 
 
 
3.3 Write down the boundary condition at the clamped wall.   This boundary condition will also not be 
satisfied exactly. 
 
3.4 Consider the Airy function 

2 2 3 5 2 3
1 1 2 1 2 3 2 4 2 5 1 2C x C x x C x C x C x xφ = + + + +  

Using (i) The governing equation for the Airy function and (ii) the boundary conditions on the top and 
bottom faces of the beam, find and solve 5 equations for the unknown coefficients 1 5C C−  .   Hence, 
calculate the stress distribution in the beam.  The algebra is best done using a computer… 
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3.5  Write down the stress distribution predicted by Euler-Bernoulli beam theory (the version covered in 
ENGN0310).  Assume a rectangular cross-section.   Use the results to suggest rough guidelines for deciding 
whether Euler-Bernoullli theory predicts the correct stress distribution. 
 
 
 
4. A shaft with length L and square cross section is fixed at one end, and 
subjected to a twisting moment T at the other.  The shaft is made from a 
linear elastic solid with Young’s modulus E and Poisson’s ratio n .  The 
torque causes the top end of the shaft to rotate through an angle f . 
 
4.1 Consider the following displacement field 

1 1 3 2 2 3 3 0v x x v x x v
L L
φ φ

= − = =  

Show that this is a kinematically admissible displacement field for 
the twisted shaft. 
 
 
 

4.2 Calculate the strains associated with this kinematically admissible displacement field 
 
 

4.3 Hence, find a formula for the potential energy of the shaft. You may assume that the potential energy of 
the torsional load is Tφ−  
 

4.4 Find the value of φ  that minimizes the potential energy, and hence estimate the torsional stiffness of the 
shaft. 
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5. Orthogonal machining model:  In this problem you will set up a simple 2D model of an orthogonal 
machining process (see the figure).    The problem uses several advanced techniques in FEA: 
(1) Modeling contact  
(2) Modeling material failure, with element deletion 
(3) Using the ‘Arbitrary Lagrangean-Eulerian’ formulation available in ABAQUS to avoid problems caused 
by large distortion of the mesh. 
 
 
The goal is to set up the model shown in the figure: a thin layer of material is removed from a workpiece 
(made from Aluminum) by a rigid cutting tool. 
 
For a unit system we will work with dimensions in mm; forces in N; stresses in MPa, and time in 
milliseconds (note that 1 m/s is 1 mm/millisecond). 
 
5.1 Start by creating parts for both the workpiece and cutting tool.  The workpiece is a 2D deformable part; 
the tool is a discrete rigid part with Wireframe base feature. Relevant dimensions are shown in the figure.  
To make it easier to position the parts in the assembly, place the top right corner of the rectangle representing 
the workpiece at the origin.   You don’t have to get the tool dimensions exactly the same as those shown in 
the figure.    Note that the dimensions are in mm. 
 

         



 
 
For mesh generation and adaptive meshing we will have to partition the workpiece as shown below.   To do 
this, first partition the block down the middle – select the ‘partition by shortest distance between two points’ 

 tool from the toolbar then select the midpoints on the two vertical sides of the workpiece.   Next, 

partition the top half of the block down the middle.   To do this select the ‘Partition face by sketch’  
tool, select the top half of the block in the viewport and press ‘Done’ then sketch a horizontal line down the 
center of the top half of the block.   You should end up with a partitioned part that looks like the picture 
shown below. 
 

     
Finally we need to add a reference point so we can apply boundary conditions to the tool.   Make sure the 
tool is shown in the viewport, then select Tools > Reference point, and select the point midway down the 
back face of the tool (see the figure above). 
 
5.2 In the Property module, create a new material called Al that will be assigned to the workpiece.  This 
publication has material properties for a Johnson-Cook plasticity/damage model for a 5xxx series Al alloy.   
Enter values in MPa  (this is convenient because 1N/mm2 is the same as 1 MPa, so forces will be in 
Newtons) 

• Young’s modulus E = 70 000 MPa 
• Poissons ratio 0.3 
• Density: 2700 kg/m3 – but we have to be careful to enter its value in a consistent set of units.  

Convince yourself that if we choose to use N for force, mm for length, and milliseconds for time, we 
must enter density in  N milliseconds2/mm4, which makes 32.7 10ρ −= ×  in our chosen unit system 

• Plasticity – (select Mechanical>Plastic and use the Johnson-Cook hardening model in the drop-down 
menu.  Then enter values of the parameters that define how the material hardens with strain and 
strain rate: 
A=277.3MPa, B=307.93MPa, n=0.69, m=0, Melting T=0, Transition T=0 (temp is neglected) 
Select Suboptions, then select ‘Rate dependent’ and select the Johnson-Cook suboption.  Enter 
C=0.0032,and Epsilon dot zero = 10-6 (in milliseconds-1) 

• Next, enter parameters that will control how the material begins to fail.  In ABAQUS failure is 
modeled by making the material soften once the strain exceeds a critical value.   To enter the 
parameters select 
Damage – select Mechanical > Damage for ductile metals > Johnson-Cook damage and enter for the 
constants: 

            d11=0.211, d2=3.9, d3= -4.7, d4=d5=0 
Finally, we need to enter a parameter that ABAQUS uses to control how elements are removed from 
the mesh after they fail.   This is really a correction factor used during the simulation rather than a 
material property.  It has two purposes: one is to make sure that the stress is reduced to zero 
gradually after an element fails; the second is to reduce sensitivity to mesh size that occurs in 
softening materials.   

http://journals.plos.org/plosone/article?id=10.1371/journal.pone.0181983
http://journals.plos.org/plosone/article?id=10.1371/journal.pone.0181983


To do this select Suboption > Damage Evolution, and enter 0.01mm for the ‘displacement at failure’ 
(this makes ABAQUS remove an element when the plastic strain multiplied by the element size 
reaches 0.01mm) 

(Read the publication cited or the ABAQUS theory manual for definitions of the constants) 
 
Finally, create a homogeneous plane section with plane strain thickness of 5mm and assign it to the 
workpiece (the block). 
 
5.3 Create an instance of both parts in the Assembly module.   
 
5.4 In the Step module, create and Explicit Dynamic step with duration 17 milliseconds (enter 17 in the 
window, not 0.017, since we are working with millisecond time units).   In the ‘Mass Scaling’ tab, check the 
radio button for ‘Use scaling definitions below’ and use Create… to define ‘mass scaling’ for the step.   The 
purpose mass scaling is to increase the stable time-step for the analysis (we will discuss this in more detail 
later in the course).    In the Edit Mass Scaling menu check the ‘Scale By Factor’ box and enter 10000 for the 
mass scaling (this is a rather too large –, but with smaller values you have to wait forever for the job to run). 
 
Secondly, make sure the ‘Status’ variable is saved to the output database (otherwise elements don’t get 
deleted and the deformed mesh looks extremely scary).  To do this select Output > Field Output Requests > 
Manager, then edit F-output-1.  Expand the 
State/Field/User/Time list of variables and 
check the Status box and press OK at the 
bottom of the editor. 
 
Next, use Tools > Set > Create to create a new set called Tool-Refpoint, and select the reference point on the 
tool.  Then use Output> History Output Requests> Create… to create a new History Output request that will 
make ABAQUS save the forces and displacements of the reference point on the tool to the output database 
(select ‘Set’ for the domain, then you can select the Tool-Refpoint set; and check the boxes in the Output 
Variables list). Save the request…. 
 
Finally, the step menu also gives you an option to activate ALE remeshing.  To do this select Other > ALE 
Adaptive Mesh Domain > Manager, and click on Step-1 and select ‘Edit’ in the domain manager.  An Edit 
menu should open: select the ‘Use the ALE adaptive mesh domain below’ radiobutton, then press the arrow 
next to ‘Region’ and select the top rectangle of the part in the viewport.  Accept all the defaults and press 
OK. 
 
 
(Optional – if you want to make a smooth animation of the cutting process you will need to select more 
frequent outputs to the odb than the default – save every 0.5 secs or more frequently) 
 
 
 5.5 In the Interaction module:  (a) create an interaction property with Hard normal contact and Penalty 
tangential contact with friction coefficient 0.1    (b) Create 
an Interaction (Interaction > Create, select Surface to 
Surface Contact (Explicit), then below the viewport select 
‘by angle’ in the dropdown menu, and click on the fillet 
radius of the tool.   The front face of the tool should be 
highlighted in the viewport.   Select the color 
corresponding to the arrow on the outer side of the tool in 
the menu below the viewport.   Then for the second surface 
select ‘Node region’ and select the rectangle at the top of 

http://journals.plos.org/plosone/article?id=10.1371/journal.pone.0181983


the workpiece.   The interaction should be highlighted as shown.  Accept the default options in the 
interaction definition menu. 
  
5.6 For boundary conditions: (1) Prescribe zero vertical displacement on the bottom of the block; (2) 
Prescribe zero horizontal displacement on the left edge of the bottom two partitions of the block; (3) Create a 
‘velocity/angular velocity’ boundary condition for the reference point with a horizontal velocity of -0.25 
mm/ms and zero vertical and angular velocity. 
 
5.7 For meshing, use Mesh> Element Type… to assign Explicit Plane Strain elements – check that the 
‘Element Deletion’ option has the ‘yes’ radio button checked -  to the workpiece, then create a mesh like 
the one below (you can create it by seeding the various horizontal edges with different mesh densities.  In the 
figure shown the top part has a uniform mesh size of 0.02mm).    Seed the tool with a mesh size 0.02mm and 
mesh it. 

 
 
 
5.8 Create a job and run it – it will take some time to complete – you can use Job> Monitor to track its 
progress. 
 
 
As a solution to this problem create a plot of the horizontal force acting on the tool as a function of time. 
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