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This tutorial will take you all the steps required to import files into ABAQUS from SolidWorks 
 
Background 
 
You often want to create a model of a part using a CAD program, and then analyze its behavior with 
ABAQUS.  ABAQUS/CAE offers several different ways you can do this: 

1. Some CAD programs (Solidworks is one example) can export an ABAQUS .inp file, which is an 
ASCII file defining the finite element simulation for ABAQUS (this usually consists of a mesh and 
loading).    You can import this directly into ABAQUS; if the file has defined the analysis the way 
you want you can simply create an ABAQUS job and run it; or if necessary you can edit or modify 
the analysis as you see fit. 
2. You can save a .iges or .step file from your CAD program. This can be imported into ABAQUS. 
3. You can import .stl files into ABAQUS.   These define the geometry of a part by specifying the 
coordinates of the corners on a huge number of small triangles on the part’s surface.   If you are very 
lucky, you can use ABAQUS/CAE to convert this data into a format that ABAQUS can use to mesh 
the part and run an analysis.    This is usually a lot of tedious and frustrating work. 

 
Creating a simple part in Solidworks 
 
 

  
 
 
 
 
1. Start by creating the simple part shown in the figure in SolidWorks (don’t worry about getting the 

dimensions exact).    
 

• Click the folder icon on the top left of Solidworks; select New, then select Part 
• Click the Features tab, click Extruded Boss/Base; select the top plane 

• Use the Rectangle tool  to draw a rectangle with center at the origin.  The dimensions are 
not important – anything roughly 10inx5in is fine.  Press the green check mark  at the top left 



• Use the centered circle tool to draw a circle at the center; again, the dimension is not important (use 
about 1.5in).  Press the check mark again.   

• Press ‘Exit Sketch’ at the top left; then enter 1.5 in for the extrusion distance in the box at the left.  
Press the check mark.  At this point your part should look like the picture below. 

 
• Before going any further, save the file in stl format (this will be imported into ABAQUS later , so 

save the file in a location that you can access with ABAQUS/CAE).  

• Select the Fillet tool  and add a 0.3inch radius fillet to the four edges of the rectangle. 
• Save your work (as a solidworks part file). 

 
2. Next, save the part as an IGES file, and a STEP AP203 file  (save the files in a location you will be able 

to access with ABAQUS).  Both these files can be imported into ABAQUS/CAE 
 

3. You can also use Solidworks to mesh your part (and run an FEA analysis as well, if you like – this is a 
good option if you want to do fairly simple simulations, 
but Solidworks does not have the extensive analysis 
capabilities available in CAE).  To do this,  
• click the Simulation tab , then click 

New Study under the ‘Study Advisor’ button on the 
top left, make sure the ‘Static’ option is checked in 
the menu, and press the green check mark. 

• Right click the mesh branch of the analysis tree on 

the left  and select Create Mesh.  The 
default mesh size is fine for test purposes.   Press the 
green check mark to generate the mesh, which should look something like the figure shown.  You 
can change the  

• Save your work – Solidworks sometimes crashes when you run the next step…. 
• To save the mesh in a format that ABAQUS can read, mouse over the arrow to the right of the 

Solidworks logo on the top left of the window   , select Simulation> Export… and 
save the file in ABAQUS (.inp) format.    The conversion will take some time to run – and to begin 
with it will seem like Solidworks is ignoring you.  When I tried this Solidworks also crashed a whole 
bunch of times before I could get it to work, and once it finally worked (after about 2 days of 
attempts) the run took about 50 mins to complete.  This is absurd for what should just be a simple 
file-writing operation, but the delay might have been caused by running remoteapp over a VPN 
connection.      A whole bunch of files will be saved along with the .inp file. 

 
You can now experiment with importing these files into ABAQUS/CAE 

 
 



IGES or STEP file import 
 
4. Start by importing the IGES file.  To do this 

• Open the Part module, and select File>Import>Part.   Try importing the part with the default options.   
You will probably get an error message saying that the part contains imprecise geometry.  The 
Simulia manual advises you to continue working with the imprecise geometry if you can – there 
should be no problem for this particular part.   If the imprecise geometry causes problems the best 
option is to try saving the file in another format and see if ABAQUS can import that.   For this part, 
you will find the step file imports successfully (you can try this if you like). 

• An IGES file gets imported as a solid part in ABAQUS and if all goes well can be meshed as if it 
had been created in CAE.   Of course you can’t edit its features (other than simple scaling, by 
copying the part) in CAE; if you need to change anything you will need to go back to solidworks and 
edit your part there. 

• Try meshing the imported part.   Go to the Mesh module.   As is, it is only possible to mesh the file 
with tetrahedral elements; as we have seen, these are not usually the best choice.    You can 
sometimes partition a part to make it easier to mesh 

• Select the Partition Cell tool from the left  
• Select 3 points, on the bottom of the 

viewport, then select the 3 points shown 
in red in the figure 

• Next, select the bottom half of the 
geometry, and create a similar partition 
to make the part symmetric. 

• If the partitioning is successful the 
middle of the part should show up 
yellow – this means it can be meshed 
with hex elements. 

• The top and bottom regions are still orange – that means they won’t mesh.   They can be meshed 
with tets – go to the Mesh> Controls menu, click anywhere on the orange region of the part.   You 
should see the color change to pink.    

 
• Use Mesh> Element type and make sure quadratic element types are assigned to all three regions 

(for both tet and hex elements). 
• You can seed the part with a 0.2 inch size and mesh it.  You will get a warning to say there are two 

regions with incompatible element types.   This reduces the accuracy of the simulations slightly, but 
(unless there are huge numbers of incompatible interfaces in the mesh) is usually not a problem.   
You can press OK to generate the mesh.   You should end up with something like the mesh shown in 
the figure. 

 
 
 
 



5. We will run a quick analysis on the part to make sure that everything imported correctly.   
• Go to the Property module, create a linear elastic material with Young’s modulus 210000 and 

Poisson’s ratio 0.3 (these are inconsistent units with inches but who cares).    
Assign the section to the part – you will have to do the 3 regions (top, 
middle, bottom) separately.  To check that this worked, go to Tools> 
Query… and from the Property Module Queries at the bottom of the 
Query menu select ‘Regions missing sections.’    You should get a 
message below the viewport that all is OK. 

• Create an Instance of the part in the usual way 
• Create a static step with period 1 unit and NLGEOM off. 
• In the boundary condition module constrain U1, U2, U3 at the entire bottom of the part to zero.  

Apply a displacement of U1= -0.00254 on the other end of the part. 
• Create a job and submit and run it (it will take some time to complete, as the mesh has 30000 

quadratic elements).   You should get contours and a deformed shape like those shown below. 

 
• Finally, verify the part dimensions.   To do this go to Tools> Query, then select Node, and click on 

one of the nodes on the top of the part – its coordinates and other parameters will be displayed below 
the viewport window. (recall that the extrusion had a height of 1.5 inches).  The dimensions are 
retained as defined in the IGES file.   But not all file formats do this, so always check what you get 
before you run an analysis! 

 
 

 
 
 
 
 
 
 



STL file import 
 

6. Now we’ll try the same thing with the stl file – this will work with reasonably simple stl files but 
otherwise .    
• Create a new model database. 
• In the part module, select Plug-Ins >Tools> STL Import  and import the STL (you can use the 

default node merge tolerance).   This will import the part (with a solid mesh) but it is useless for 
analysis purposes. 

• To use the part in an FEA analysis, it needs to be converted to a solid geometry that can be meshed.   
You can use the Geometry Edit tools to do this.   Select Tools> Geometry Edit, check the ‘Face’ 
radio button in the Geometry Edit window, then highlight ‘From element faces’ 

• You now need to work your way around the part and convert the elements into faces.  Start by doing 
the sides of the box – select ‘By angle’ to define how the faces are selected (‘By analytic’ works 
too), then select one side of the box (see below) and press ‘Done.’   Repeat this for all four sides, the 
top, then the base.   After this the part should look like the figure on the right below (all four sides 
should be white).    

  
• Next use the ‘By Analytic’ option and select the hole.  (You will get a warning when you do this)  

After this the entire part should be white.                
• We now have a shell part.  To convert it to a solid, go to Shape> Solid> From Shell; select 

Individually in the dropdown menu below the viewport, and drag a rectangle around the entire part 
to select it.   Then create the solid part. 

• To update the part validity you can go to the Part menu, select Part>Manager, select the part and 
press the ‘Update Validity’ button; you can also right-click on the part (if you can find it) in the 
model tree. 

• Save the model database – ABAQUS will sometimes crash during subsequent work…. 
• You should now be able to assign properties to the part, mesh it, define boundary conditions and run 

an analysis.  Go ahead and try this… set up the same analysis as in 5.6 and run the job.   You should 
see something like the results below.  Note the contour levels are quite different!! 

 



• Finally, verify the part dimensions.   To do this go to Tools> Query, then select Node, and click on 
one of the nodes on the top of the part – its coordinates and other parameters will be displayed below 
the viewport window. (recall that the extrusion had a height of 1.5 inches).  The dimensions get 
converted to mm in an STL file!!.    

 
NB This example works fairly seamlessly, but in practice creating a solid part from an STL file in 
ABAQUS can be extremely difficult, especially if the file contains a huge number of facets. For 
example, the part with the fillet radii included is virtually impossible to convert.  If you need to 
work with an STL file its usually better to import it into Solidworks and then save it in some other 
format, rather than using the ABAQUS tools.   But you can only use solidworks for research if 
your adviser pays the license fee so if this wasn’t written into your grant proposal you may be 
stuck with ABAQUS… 

 
 

ABAQUS .INP File Import 
 
7. Finally, we’ll try importing the ABAQUS format .inp file.   Solidworks does not always save these 

correctly (it works better if you set up a complete analysis in Solidworks, but we just exported the mesh) 
but fortunately .inp files are simple ASCII text files that can easily be fixed if you are old enough to 
remember the old days when we used to set up analyses by creating a .inp file by hand.    
• Open the .inp file with a text editor (wordpad will work) and find the line that says 

*ELEMENT,TYPE=C1D2,ELSET=PART1_EG1 
• Change the C1D2 to C3D10 (this is the 10 noded tetrahedral element in ABAQUS.  There might be 

some situations when you might want to switch this to one of the other options C3D10M, C3D10H 
and C3D10I – see this article for more details) and save the file.  If you edited with wordpad, close 
wordpad otherwise ABAQUS can’t access the file. 

• Open CAE, use File > Import…  Model, then select the .inp file.  The Part list will be updated and 
the Assembly will include an instance of the meshed part.    If you used Solidworks to define 
boundary conditions these will also be imported, but sometimes in a rather strange format – for 
example pressure applied to element faces gets converted to forces applied to nodes (saved one line 
at a time in the file). 

• Note that when you import a Model, a new one is added to the model tree 
at the left – the original one is empty.  Make sure you select the right one, 
otherwise you will just see nothing!  If you like, you can delete Model-1 (right-
click the branch in the tree and select Delete) 

• To check that the imported part can be analyzed, go to the Property module, create a material with 
Youngs Modulus 210000 (arbitrary units), Poissons ratio 0.3, create a solid homogeneous section, 
select Assign> and select Individually from the menu below the viewport, then drag a box around 
the entire part to select all the elements.    Select Section 2 from the drop-down menu of sections, 
and then OK. 

• create a step with period 1 and NLGEOM off; 
• In the Load module, create a BC, select Displacement/Rotation, the select ‘By Angle’ from the 

dropdown menu below the viewport, and click on the end of the part. All the nodes on the end 
should be highlighted.  Fix U1 U2 U3 to zero on this node set.  Repeat the process to apply a 
displacement of U1=-0.1 at the other end of the part. 

http://optimec.ca/news/tetrahedral-elements-available-abaqus-structural-analysis-use/


 
 

• Create a job and submit it.  This job should run quickly; the mesh is coarse.   If the import and model 
definition was successful you should see the results below in the Visualization module. 

 
• Important: Check the nodal coordinates of the model.  To do this go to Tools> Query, then select 

Node, and click on one of the nodes on the top of the part – its coordinates and other parameters will 
be displayed below the viewport window. (recall that the extrusion had a height of 1.5 inches).  Note 
that the part dimensions have been converted to meters! 
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