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This tutorial will take you all the steps required to  set up and run a basic simulation using 
ABAQUS/CAE and visualize the results; 
 
 
 
 
Background 

             
 

1. The figure shows an FEA simulation of a rigid sphere rebounding of a soft rubber thin film.   
• The sphere is idealized as a near-incompressible neo-Hookean hyperelastic material (we will discuss 

what this means later in the class – for now, all you need to know is that this material model is often 
used to model elastomers).  The solid has shear modulus µ ,  bulk modulus K and mass density ρ .  
We will focus on the limit where K µ>>  . 

• The sphere has radius R, mass m, and is launched with initial velocity 0V towards the rigid surface. 
 
In this tutorial you will run a finite element simulation of this problem.    
 
1. Open ABAQUS/CAE (you will find a link on the Start menu).   From the 
‘Start session’ menu select ‘Create Model Database’ with Standard/Explicit 
Model 
 
2. To set up and run a simulation in CAE, you can either work through the 
various ‘Modules’ in the dropdown menu at the top of the screen, or you can 
click on the menus in the workflow tree on the left hand side of the screen.  
We will do the former in this tutorial. 
 



3. The ‘Part’ module is used to define the geometry of the various interacting 
solids in the simulation.  Here, we will create the elastomeric film and the 
rigid cylinder as two separate parts. Start by creating the sphere: 

a. Select Part>Create from the top menu bar, then use the menu that 
comes up to name the part ‘Sphere;’ select ‘Axisymmetric’ and 
‘Discrete Rigid’ for the Modeling Space and Type, and enter an 
Approximate Size of 0.75.  (you can try ‘Analytical Rigid’ as well if 
you like, but ABAQUS will sometimes throw an error when you try to 
make a semicircle with this option) 

b. Use the sketch tools from the left to draw a semicircle, centered at 
(0,0.05), with a radius of 0.05 

c. To exit the sketch menu, click the circle sketch tool to unselect it (or 
you can click the sketch window with both mouse buttons and select 
‘cancel procedure’), then select ‘Done’ from the menu below.  

 
Rigid surfaces need a ‘reference point’ that can be used to define the motion of the part, or forces acting on 
the part.   To add a reference point to the cylinder Select ‘Tools>Reference Point’ in the Part module, and 
select the point at the center of the sphere. 
 
Next, create the film: 

a. Select Part>Create; name the part ‘Film’, and select ‘Axisymmetric’ and 
‘Deformable;’ 

b.  Draw a rectangle – the exact dimensions are not important, but place the 
top left corner of the rectangle at the origin.    Exit the sketch menu. 

 
If you need to make any changes to the parts, you can do so using the Model Database tree on the left- you 
can expand the various options and edit them as needed. 
 
4. Next, we will define material properties, and assign them to the parts. 

a. Switch the ‘Module’ to ‘Property’  
b. To create a hyperelastic material, select Material>Create 
c. Change the name of the material to ‘Hyperelastic’.   To define 

properties, Select ‘General’ on the popup window, and enter a density value of 1. 
d. Next select the Mechanical>Elastic>Hyperelastic.   In the menu that comes up select ‘Neo 

Hooke’ for the strain energy potential, click the ‘Coefficients’ 
radio button, and enter a value of 1.0 for C10.  Leave the D 
field blank – if you do this, ABAQUS will assign an internal 
value that makes the material approximately incompressible. 

e. Next, you have to create a ‘section.’  This makes more sense 
for parts like beams or truss elements, where you need to 
define the geometry of the cross section, but you have to do it 
even for a 3D part.   Select Section> Create, then select 
Homogeneous Solid section from the menu, set the options in 
the Edit Section menu as shown, then check that press OK from the menu shown 

f. Switch the ‘Part’ to Film, then select Assign>Section. Click on the 
rectangular film to select it (it should turn pink), then select ‘Done’ from 
the bottom of the window. This has now assigned the hyperelastic 
material model to the part representing the film.   If you want to make a part heterogeneous, you 
can partition it, and assign different properties to the different partition. 

g. Next, create the inertial properties of the rigid sphere.   Switch the ‘Part’ to Sphere, then select 
Special> Inertial Properties. 



h. On the popup window rename the property to Sphere-Inertia, then select Point mass/inertia, then 
press Continue 

i. Select the reference point in the sketch window.  
j. On the menu that comes up, enter a mass of 0.2 units.  The inertia can be left blank, since the 

axisymmetric boundary condition does not allow the sphere to rotate. 
 
5. Now we create an assembly of the parts.   

a. Switch the ‘Module’ to Assembly 
b. Select Instance>Create 
c. On the menu select the Sphere; check the ‘Independent’ radio button, make sure the ‘auto offset’ 

is unchecked, then press OK 
d. Repeat b-c to create an instance of the film.  You should end up with the window shown below. 

 
6. Save the model database to a file named Sphere-Film-Impact.cae 

 
 
 
7. Next, we define the ‘Step,’ which specifies the time interval of the simulation, as well as various options 

defining the finite element algorithms.  The ‘Step’ module is also used to define variables that will be 
saved to the output database during analysis. 

a. Select the Step module 
b. From the top menu select Step>Create 
c. In the menu that appears select Dynamic, Explicit, and make sure the Procedure type is 

‘General’ 
d. On the next menu name the step ‘Impact’, make sure the NLGEOM box is checked (this will 

ensure ABAQUS runs as finite strain computation) and enter a time period of 2.0 on the Basic 
tab.  You can leave the other options at their default values, but take a look at the tabs to see 
what the Step menu allows you to control. 

e. The Step module also allows you to select variables to write to the database.   In this example, 
we will set up ABAQUS to save the vertical displacement and velocity of the center of the 
sphere so it can be plotted later.   We first need to define a node set that will contain the 
reference point at the sphere center: Tools>Set>Create; then in the Create Set menu name the set 



Sphere-Ref-Point; select Geometry, and press Continue.   Then, select the reference point on the 
sphere, and press Done. 

f. To create the output request use Output>History Output Requests> Create.  Name the history 
output Sphere Motion and press 
continue.    

g. Then, in the Edit History Output Request 
menu, for the Domain select Set; and 
select Sphere-Ref-Point for the set.   For 
Frequency, select ‘Every n time 
increments’ and enter 1 for n.   Check the 
‘Displacement/Velocity/Acceleration’ 
box, and then edit the menu to show 
U2,V2,A2 (the vertical displacement, 
velocity and acceleration).   Finally, 
press OK.  

8. Next, we set up the properties of the contact between the sphere and the film.   Select the ‘Interaction’ 
module to start 

a. First, define the properties of the contact.  Select Interaction>Property>Create 
b. Name the property Hard-frictionless and select the Contact option, then press continue 
c. Select the Mechanical > Normal Behavior option and accept the defaults;  
d. Select the Mechanical > Tangential Behavior; check that the friction formulation says 

Frictionless, then press OK 
e. Next, specify the two surfaces that will contact: select Interaction>Create 
f. Name the interaction Sphere-Film-Interaction and apply it to the Impact step 
g. Select the Surface-to-surface contact option; press Continue 
h. Click the outline of the sphere in the window to select it, press Done, then select color of the 

arrow pointing towards the outer surface of the sphere (ABAQUS needs to know whether the 
contact will occur from inside the sphere or the outside) 

i. For the second surface, select the Surface option, then click the surface of the film, then press 
Done 

j. In the ‘Edit Interaction menu, check that ‘Finite Sliding’ is selected, the interaction property 
should be Hard-Frictionless.  You can accept defaults for the other options.   Press OK.  You 
should see the interacting surfaces marked with small rectangles in the window 

Now that the interaction has been created, we can 
configure CAE to save results associated with the 
contact to the output database.   To do this, return to 
the ‘step’ module (i.e. part 7 above), then  

k. select Output>History Output 
Requests>Create 

l. Name the history request Contact-Force, 
and apply it to the Impact step 

m. Select ‘Interaction’ for the domain 
dropdown menu; select ‘Every n time 
increments’ and set n=5 for the 
Frequency, and then activate the total 
forces due to contact pressure and the 
total contact area (see the figure) 

 
 
 



9. Next, we specify boundary conditions and initial conditions for the analysis.  Switch to the ‘Load’ 
module. 

a. To enforce the axial symmetry boundary condition for the film, select BC>Create; then in the 
Create Boundary Condition menu, name the boundary condition Film-Axial-Sym; select the 
initial step; the Mechanical category, and the Symmetry/Antisymmetry/Encastre type; then press 
Continue. 

b. Select the leftmost side of the rectangular film 
c. Select the XSYMM option, and press OK (note that the UR2 and UR3 degrees of freedom are 

not active for the film, even though they show up in the menu) 
d. To constrain the vertical velocity of the base of the film, select BC>Create; in the Create 

Boundary Condition menu name the boundary condition Film-Base; select the Initial step; select 
Displacement/Rotation, and press Continue 

e. Select the base of the film and press Done 
f. In the Edit Boundary Condition menu select U2 and press OK 
g. To enforce the axial symmetry boundary condition for the sphere, select BC>Create 
h. Name the boundary condition Sphere-Axial_Sym; select the Initial step, the Mechanical 

category and Symmetry/Antisymmetry/Encastre and press Continue 
i. Select the reference point (RP) on the sphere and press Done 
j. Select XSYMM on the Edit Boundary Condition menu and press OK 
k. To specify the initial downward velocity of the sphere, Predefined Field>Create 
l. Name the field Initial-Vel-Sphere; select the Initial step, the Mechanical category and the 

Velocity type.  Press Continue 
m. Select the reference point (RP) on the sphere 
n. Enter -0.05 in the V2 box on the Edit Boundary Condition menu, and leave the V1 box blank.   

Press OK. 
 

 
 
 
 
 



10. The analysis will need a finite element mesh (the film must be meshed; and if the sphere is a Discrete 
Rigid surface, it must also be meshed.   It is not necessary to mesh an Analytical Rigid Surface).  Select 
the Mesh module 

a. Start by meshing the film.  To specify the element type that will be used in the analysis, select 
Mesh > Element Type; then click on the film, and select Done. 

b. In the Element Type menu, select the Explicit element library, and select the default settings 
c. To specify the mesh generation algorithm that will be used, select Mesh > Controls; then click 

on the film, and select Done. 
d. In the Mesh Controls option select Quad for the element shape, and the Medial Axis algorithm, 

and press OK.   You may need to press Done in the assembly window again to exit the mesh 
controls menu 

e. To specify the element size to be used, select Seed>Instance, then select the film, and press 
Done. 

f. In the Global Seeds menu enter 0.0025 for the mesh size, and press OK.  Press Done in the 
assembly window to exit the Seed definition. 

g. Finally, to mesh the film, select Mesh>Instance, select the film, and enter Done 
h. If the sphere is a Discrete Rigid part, it will also need to be meshed.   To specify the mesh size, 

select Seed>Instance, then select the sphere. 
i. In the Global Seeds menu enter 0.0025 for the mesh size, and press OK.  Press Done in the 

assembly window. 
j. To mesh the sphere, select Mesh>Instance, then select the sphere; press Done to exit. 

 
11. Finally, you will need to set up and submit an analysis.  Select the Job module to do this 

a. Select Job>Create… 
b. Name the job Impact-Simulation.  You can accept the defaults for all other options, and press 

OK 
c. To run the analysis, select Job>Submit.   If ABAQUS detects any problems in defining the 

analysis, it will throw errors and warnings.    
d. You can view the progress of the analysis, along with warning messages, by selecting 

Job>Monitor.   You will see one warning, which is harmless.   As the analysis runs, information 
about each step will be displayed in the Impact Simulation Monitor window 

 

 
 
 
 
 
 
 



12. ABAQUS also creates a large number of files during an analysis.   You can find them in the ABAQUS 
working directory.  The following files can be viewed using a text editor and may contain useful 
information (eg error messages if an analysis fails).  It’s worth checking each to see what they contain: 

a. Impact-Simulation.inp is an ASCII file that defines the finite element simulation.  This is how 
ABAQUS/CAE (which is just a GUI) communicates with the ABAQUS finite element platform.  
We often edit this file and run ABAQUS with it directly when we use ABAQUS with user-
element or user-material subroutines.   See the last section of this tutorial for more details. 

b. Impact-Simulation.log summarizes the outcome of each phase of the analysis 
c. Impact-simulation.sta is updated during analysis to show its progress 
d. Impact-simulation.msg contains error messages 
e. Impact-simulation.dat contains both error messages and the output of an analysis.   It is 

sometimes the only way to easily view results of an analysis that has user elements. 
 

13. Once the job was completed, you can view the results.   To do so, start by selecting the Visualization 
module. 

a. You will need to load the ‘output database’ by using File>Open…  then navigate to the 
ABAQUS working directory (if needed), and open the file called Impact-Simulation.odb 

b. You can now explore the results of the simulation.   For example, to plot von Mises stress 

contours on the deformed mesh, select   

c. You can now use the  buttons to scroll through the history of the simulation. 
d. You can view an animation of the impact by selecting Animate > Time History.   You can 

change the behavior of the animation by selecting the Options > Animation menu. 
e. If you would like to plot contours of variables other than the Von Mises stress, go to 

Result>Field Output.  The Field Output menu will allow you to select different variables.   If you 
don’t see the variable you want to plot that usually means ABAQUS did not save it to the odb.  
To get it, you will need to go back to the Step menu, and use the Output> menu to add the 
variable you are interested in.   The analysis will need to be re-run.     

f. You can change the way the contour plots look by using the Options>Common menu, or 
Options>Contour. 

g. Some additional features of the viewport can be controlled using the Viewport>Viewport 
Annotation Options. 

h. You often want to change the background of the viewport to save plots for reports – you can do 
this using the View>Graphics Options menu 

i. ABAQUS can also plot graphs showing spatial or temporal variation of quantities of interest.  
For example, to plot the contact force acting between the sphere and the film as a function of 
time, you can use Result>History Output…   and then select Total force due to contact pressure: 
CFN2 ASSEMBLY_M_SURF-1/ASSEMBLY_S_SURF-1  (you can select either of the CFN2 
variables – one is the force on the sphere; the other is the force on the film. 

j. ABAQUS/CAE also allows you to post-process data.  For example, you can save the contact 
force history to a dataset using Tools>XY Data>Create; then select Odb history from the XY 
Data menu.    To change the data, you can use Tools>XY Data> Create, then select Operate on 
XY data.   The menu that opens allows you to enter formulas that create new XY datasets by 
modifying existing ones.    In practice it’s usually easier to post-process odb data by writing a 
python script that will read and modify data extracted from an odb, however. 

k. Similarly, you can plot the velocity or displacement of the center of the sphere, by using 
Result>History Output, and then select Spatial velocity: V2 Pl: SPHERE-1 Node nn in NSET 
SPHERE-REF-POINT’; then press plot 

l. The visualization module has many other features; if you have time, the best way to learn them 
is just to explore all the various options and see what happens. 
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