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ENGN40 will be using Matlab ‘Live Scripts’ instead of Mupad. 
You can find information about ‘Live Scripts’ in the ENGN40 MATLAB tutorial 
 
1. What is Mupad? 
 
Mupad is a GUI driven MATLAB package that helps you do algebra, calculus, as well as to graph and 
visualize functions.   As you know, MATLAB is good for writing simple programs and working with 
numbers, but is cumbersome for doing symbolic calculations.  In contrast, Mupad works with symbols by 
default, and has a nice menu-driven interface.   
 
2. Starting Mupad 
 
You run Mupad by first starting MATLAB (see the Matlab tutorial if you don’t know how to do this), 
then typing  

>>  mupad  
in the MATLAB command window.  Start mupad now, and type in the commands as they appear in the 
tutorial.   You might find it helpful to experiment and explore the various functions on your own as well. 
 
3. Basic Mupad window 
 
You should see the GUI shown below.  Most of the buttons should be self-explanatory.   Try clicking a 
few at random to see what happens… 

Mupad function shortcuts

Enter Mupad
commands here

Shortcut to plotting

Mupad helpExecute

Insert new line

 

http://www.brown.edu/Departments/Engineering/Courses/En4/Tutorials/MATLAB_tutorial_2017.pdf


 
4. Simple arithmetic calculations  
 
Just like MATLAB itself, Mupad can be used as a calculator.  Try the following commands 

 
 

Here, the gamma function and besselJ are special functions – the gamma function is the generalization of 
the factorial to non-integers, and the Bessel function is the solution to a common differential equation. 
Mupad has lots of built in special functions, which can be very useful. Notice also that, unlike MATLAB, 
Mupad returns the correct answer for sin(PI).  This is because by default, Mupad is not working with 
floating point numbers.   It will return the exact answer to any calculation.  It will only start using floating 
point calculations if you start first, or explicitly ask for a numerical value.  For example, contrast 

 
In the second case, Mupad gives a floating point number because you typed in a floating point number 
(0.5) as the argument to the Gamma function. You can also ask Mupad to compute a numerical value for 
an expression with the ‘float’ function 

 
Note the use of the % character – this always refers to the result of the last calculation that Mupad has 
done. 
 
Note that unlike the MATLAB command window, Mupad lets you go back and change any line, and will 
then let you execute the file again with the changed code.  The Notebook>  menu gives lots of options for 
re-doing calculations after a correction. 
 



5. Help 
 
Mupad will automatically open the help page for the MATLAB symbolic math toolbox. You can start 
help by pressing the question mark on the command ribbon or by going to Help, or by pressing the F1 
key. 

 
Note that the ‘Search Documentation’ box in the help window will search the whole MATLAB help, not 
just Mupad, so it’s not very useful.  But you can find a lot of Mupad examples and information by 
clicking on the ‘Mupad’ part of help.   
 
Try browsing around in the help pages for a bit to get a sense of what is in there. 

 



6. Saving your work 
 
You can save your work in a Mupad ‘Notebook’ (a bit like a MATLAB script) by going the the File>Save 
menu.   The file should be saved with the default .mn extension.   Mupad is fairly robust, but it does crash 
unexpectedly now and again (usually when you try to resize a window), so it’s worth saving lengthy 
calculations frequently. 
 
Mupad notebooks can also include detailed comments and annotations that help readers follow what the 
calculations are doing.   To insert a text paragraph, just hit the  button, or use Insert>Text Paragraph.   
Use Insert> Calculation to go back to typing in math, or use the  button. 
 
You can also export a Mupad notebook to html or pdf format, if you want to publish your work. 
 
 
7. Basic algebra 
 
 
Mupad is quite good at doing algebra.  For example, it can solve equations 

 

Because there are two solutions, they are returned in a set (enclosed by {}).  You can extract each one by 
using the [number] convention. 

IMPORTANT: Notice that the ‘equals’ sign is used in two different ways.   If you just type a=b, you 
have created an equation object that you can use in later manipulations (e.g. solve it!).   On the other 



hand, if you type a :=b^2 (with a colon) then you have assigned the value b^2 (a symbol) to a variable 
called a.  Mupad will substitute b^2 for a any time it is used later.  For example try this 

 

 
Notice that a in the ‘eq1’ object has been replaced by b^2. You can clear the value of a variable using the 
‘delete’ function 

 

 
 
If you want to clear all variables, you can use the ‘reset’ function.  This completely restarts mupad from 
the beginning.  This is often useful for starting a new homework problem. 
 
Let’s try some more algebra 

 
 
Mupad doesn’t simplify expressions by default.   But it can do so if you ask it to 

 
 
This sort of thing is especially handy for trigonometric functions 



 
 
Mupad can solve systems of equations too 

 
 
You often want to solve an equation or system of equations, and then substitute that solution into a third 
equation.  You can use the ‘subs’ function to do this 

 
 
All the [1]s and [2]s here are hard to understand.   Their purpose to extract the solutions from the variable 
‘sol.’   Notice that ‘sol’ is in curly parentheses {} (look at the example at the top of the page) – this means 
sol contains a set (which happens to contain only a single solution – but in more complicated problems 
there might be more than one solution).  You need to extract the solution you want out of this set.  Thus, 
sol[1] extracts the first (and only) element from the set.   In the first example, both the solutions for x and 
y are extracted and substituted into eq3.   In the second example, sol[1][1] substitutes only x.  In the third, 
sol[1][2] substitutes only y. 
 
Of course not all equations can be solved exactly. 



 
But you can get an approximate, numerical solution 

 
You can find more information about equation solving in the Mupad help documentation… 
 
 
 
8. Plotting 
 
Mupad is very good at plotting and graphics. For a basic plot, try 

 
 
You can control the range of the plot as follows 



 
The ‘plotfunc2d’ command does the same thing as plot but has more options to control the appearance of 
the plot 

 
 
Another way to do a plot is to select Plot Commands>Function Plots>2D Function from the menu on the 
right.  The command will appear in the mupad window – you need to put in a function and range to 
replace the dummy arguments #f and #x=#a..#b .  You will find the plot appears to do nothing.  To 
display the plot you have to enter ‘display(%)’ on the next line 



 
 
You can display multiple plots on the same axes 

 
 
If you have no life and love to read help manuals, you make very fancy looking plots 



 
 
(I do have a life – although there may not be much of it left - and hate to read manuals, so I just copied 
and pasted an example directly from the mupad help).  You can do pretty 3D plots as well 

 
 
Click on the plot, and then try experimenting with some of the buttons on the toolbar window – you can 
rotate the plot around, zoom in, and so on. 
 
You can make animations as well, by adding a 3rd parameter to a 3D plot (a in the example below).  To 

play the animation, click on the picture, then press the big blue right pointing arrow.  
 



 
Mupad can do parametric plots as well, in both 2D and 3D.  Try this 

 
 
 
(The second plot here is an animation – you have to click on the plot to start the animation).  You can plot 
3D surfaces as well 



 
 
The ‘implicitplot’ is another very useful function.  In 2D, it will plot a line or curve that satisfies an 
equation.  In 3D, it will plot a plane or surface that satisfies a 3D equation.  Here are two simple 
examples. 
 



 
 
 
 
Saving plots: If you would like to include a plot in a report, you can click on the figure, then use 
Edit>Copy Graphics, then paste the figure into your document.  You can also export the figure to a file in 
various formats (you will need to do this to save animations) using File>Export Graphics. 
 
 
 
 
 
 
 
 



9. Calculus 
 
Mupad is great at calculus.  Try 

 
 
Mupad can do partial derivatives as well 

 
 
It can also do definite integrals 

 



Try the integral without the ‘assume(‘&sigma;’>0) as well (just say delete(‘&sigma;’) and do the integral 
again – you get a big mess).  Notice also that Mupad interprets log(x) to be the natural log – this is 
standard practice in math and engineering (log10 very rarely comes up except in signal processing e.g. to 
define things like decibels). 
 
Of course not all integrals can be evaluated…  But definite integrals can always be evaluated numerically. 

 
Another very useful application is to take limits and Taylor series expansions of functions 

 
 
Here, the ‘expr(%) gets rid of the funny O(x6 ) that denotes how many terms were included in the series – 
this can be useful if you want to substitute the Taylor expansion into another equation later. 
 
 Mupad will also sum series for you – but we won’t need that much in EN40.   You can explore it for 
yourself if you are curious. 
 
10. Finding maxima and minima 
 
You can use Mupad to do the usual calculus to maximize or minimize a function.   For example, let’s try to find the 
maximum value of  

4( ) exp( )f x x x= −  
To do this by hand, you would (i) find the values of x that make f stationary, i.e. solve / 0df dx =  , and 
(ii) substitute the solution(s) back into the function.  Here’s the Mupad version of this 



 
 
 
Notice that Mupad gives all the roots of / 0df dx = .   We have to work out which one corresponds to a 
maximum.   You can do this by plotting the function, or in this case we can see that x=0 has to be a 
minimum (since f>0 everywhere else!) .  The statement subs(f,x=xatmax[2]) substitutes the 
second root back into f. 
 
 
 
11. Solving differential equations 
 
Mupad can also solve differential equations – both analytically, and numerically (but in this course we 
will use MATLAB whenever we want a numerical solution).  For example, let’s solve the differential 
equation from the MATLAB tutorial: 

10 sin( )dy y t
dt

= − +  

given that 0y =  at time t=0.    

 



Notice that Mupad gives a formula for the solution (recall that MATLAB only gives numbers).  Here’s 
another example – this is the differential equation governing the free vibration of a damped spring-mass 
system, which will be discussed in painful detail later in the course 

 
 
Here, we used the notation 

2

2( ) ( )d y dyy t y t
dtdt

′′ ′≡ ≡  

Again, mupad gives an exact solution – but it’s not very easy to visualize what the solution looks like!  If 
we substitute numbers we can plot it 

 
 



Of course, not all differential equations can be solved exactly. 

 
Mupad now gives no solution.   It is possible for Mupad to compute a numerical approximation, but in 
most cases it is more straightforward to use MATLAB  if an analytical solution cannot be found.   We 
will use MATLAB exclusively for this purpose in this course. 
 
 
11. Vectors and Matrices 
 
Finally, we’ll take a look at Mupad’s functions that deal with vectors and matrices.  Strangely, vector and 
matrix manipulations are more cumbersome than most of Mupad’s capabilities – even doing a trivial 
thing like a dot product is a chore.   Here are some basic vector/matrix manipulations. 

 
 



These commands create row and column vectors; a matrix’ multiply a matrix by a vector (to produce a 
column vector); multiply a column vector by a row vector to produce a scalar, and do a dot product of two 
vectors (the scalar product) in two different ways.  Note that by default Mupad assumes that all variables 
could be complex numbers – hence the complex conjugates unless you specify ‘Real’ in the 
ScalarProduct function. 
 
Mupad can do fancy things like cross products and vector calculus (curl, divergence, etc).  It can even 
find the scalar potential corresponding to a curl free vector field (useful for calculating the potential 
energy of a force, for example).   It can find a vector potential for a divergence free vector field too (not 
so useful for us here…) 

 
 
This should be enough to get you started, but we’ve only looked at a small subset of Mupad’s capabilities.   
You might like to explore the help manual to find more obscure tricks. Mupad can be useful in many of 
your courses, not just EN40! 
 
 



COPYRIGHT NOTICE: This tutorial is intended for the use of students at Brown University.  You 
are welcome to use the tutorial for your own self-study, but please seek the author’s permission 
before using it for other purposes. 
 

A.F. Bower  
School of Engineering 

Brown University 
December 2016 
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