HAVING DIFFICULTY FINDING PLME ESSAY QUESTIONS ON COMMON APPLICATION?

Having difficulty finding PLME essay questions on the Common Application?    The folks at Common App have told the Brown Admission Office that students who have been experiencing difficulty have been using unsupported browsers.  The list of CA supported browsers is below.  Though the list includes Internet Explorer 9, they have found it to be buggy and recommend using either IE 10 or a different browser all together.

Common Application System Requirements

The following operating system and browsers are supported:

PC (Windows XP/Vista/7)

  • Current version of Chrome
  • Current version of Firefox
  • Internet Explorer 9 or higher

Mac (OS X Tiger / Leopard / Snow Leopard)

  • Current version of Chrome
  • Current version of Firefox
  • Safari 5.1 or higher

Regardless of browser, please make sure the following browser settings are correct:

  • Javascript must be enabled.
  • Cookies must be enabled.
  • Popup blockers must be disabled.

Other Software needed: 
To view and print PDF files we recommend Adobe Reader 10 or higher. While PDF files should work with most other pdf viewers, we can only guarantee full compatibility and support for Adobe Reader 10 or higher.

Email: 
If your email offers a whitelist, please add the following address: 
appsupport@commonapp.net