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Tonight:

• Introduction to external analysis 

products

• ABAQUS

Last time:

• More motion analysis with 
Pro/E
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External Analysis
Advanced analysis typically is done in problem-spec ific packages 

ABAQUS
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Structural Analysis
Utility and Applications

• Structural Analysis is used to predict the response  of a solid to an applied 
load

• Response is typically linked to some performance cr iteria of component

• Yield

• Fatigue
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• Fatigue

• Rupture

• Frequency response

• Predictions need to capture correct physics

• Correct predictions (or “virtual prototyping”) can ha ve a huge impact on 
product development



Structural Analysis
Key Concepts

• Solids and structures are analyzed in terms of stres ses and strains

• Stress – measure of the internal forces acting in a solid

• Strains – describes deformation of a solid

• Stresses and strains provide a mathematical languag e to quantify material 
response
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response



Structural Analysis
Finite Element Method

• FEM uses a divide and 
conquer approach

• Approximate the 
geometry using a 
collection of nodes 
and elements
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• Satisfy equilibrium 
on each element

• Displacements are 
calculated directly

• Stresses and strains are 
calculated from 
displacements



Structural Analysis
Finite Element Method – Process layout

• Establish the geometry (CAD)

• Pre-processing

• Material definition

• Discretization (meshing)
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• Establish boundary conditions (loads and displaceme nts)

• Solver settings

• Solution

• Post-processing

• Evaluating the results

• Interpreting the results – MOST IMPORTANT PART!!



Structural Analysis
Finite Element Method – Packages

• Many CAD systems come with internal analysis softwa re

• Typically very limited

• True mathematics and physics are often “package” to b roaden 
number of potential users

• There are very strong third party packages availabl e that specialize in this 
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• There are very strong third party packages availabl e that specialize in this 
type of analysis

• ABAQUS

• ANSYS

• ALGOR

• ….many others

• These types of codes provide the largest flexibilit y and versatility



EXERCISE - Structural Analysis
Employing Finite Element Method

• Using FEM assess 
whether the pipe section 
shown can support an 
internal pressure of 500psi

• Assume:
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• Symmetry can be 
employed

• Component is 1018 
steel



EXERCISE – Structural Analysis

• Download 
pipe_flange.prt from the 
Supporting Materials 
page of the web site

• Open the component in 
Pro/Engineer
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Pro/Engineer



EXERCISE – Structural Analysis
De-feature CAD model

• We don’t need this level 
of detail to perform the 
analysis we’re interested in

• Best practice > 

• Wherever possible 
suppress instead of 
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suppress instead of 
delete

• Suppress chamfers and 
rounds that are not 
structural

• Note: Keep Round 2



EXERCISE – Structural Analysis
De-feature CAD model

• Round 2 will definitely 
have a non-negligible effect 
on the stress in the 
component 

• Can’t get rid of this!
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EXERCISE – Structural Analysis
Symmetry

• When possible, symmetry 
can aide an analysis 
substantially

• Ease application of 
BC’s

• Reduces 
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• Reduces 
computation time 
required

• Cut the model along the 
two datums shown



EXERCISE – Structural Analysis
Symmetry

• This should be all that’s 
left

• If you’re here, you’re 
ready to export the model
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EXERCISE – Structural Analysis
Export Geometry

• File > Save a Copy…

• Select STEP as the file 
type

• Keep the same file name
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EXERCISE – Structural Analysis
Export Geometry

• From the Export STEP 
options dialog box

• Un-check Shells

• Make sure Solids 
are checked
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• Keep all other 
default preferences

• Click OK 



EXERCISE – Structural Analysis
Open ABAQUS

• ABAQUS is a third party 
Finite Element Analysis 
package

• Note the GUI layout > 
Very similar to Pro/E

• Model Tree
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• Model Tree

• Command Icons

• Click Create Model 
Database to get started



EXERCISE – Structural Analysis
Import our geometry

• File > Import > Part

• Navigate over to our 
STEP file

• Click OK
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EXERCISE – Structural Analysis
Import our geometry

• Create Part... Dialog 
pops up

• On Name – Repair 
dialog check 
Convert to precise 
representation
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representation

• Keep the defaults on the 
other pages, but look over 
what is available

• Click OK

• STEP is loaded

• This will take a 
minute



EXERCISE – Structural Analysis
Get familiar with the interface

• POSSIBLE THE MOST USED 
FUNCTION – Spin, Pan, Zoom 
is DIFFERENT!

• For either Spin, Pan or 
Zoom start by holding 
the Crtl + Alt Key
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the Crtl + Alt Key

• Spin – Crtl + Alt + LMB

• Pan – Crtl + Alt + MMB

• Zoom – Crtl + Alt + RMB

• Try this until comfortable



EXERCISE – Structural Analysis
Get familiar with the interface

• The ABAQUS/CAE interface 
is broken up into a number of 
modules

• Definitions established in 
these modules set necessary 
parameters and options for an 
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parameters and options for an 
analysis

• Working through these one at 
a time makes the setup 
process very orderly



EXERCISE – Structural Analysis
Part Module

• Importing the STEP file 
completes everything we need 
in the part module

• Expand the Model Tree to see 
the STEP file name

• Take a look at the geometry 

BCB – Apr. 26, 2012 EN1740, S2012

• Take a look at the geometry 
tools in ABAQUS

• You can create solid 
models right in 
ABAQUS

• If you know Pro/E, don’t 
do this



EXERCISE – Structural Analysis
Property Module

• Define material properties

• Material > Create

• Rename the material 
1018-steel

• For Material 
Behaviors select 

BCB – Apr. 26, 2012 EN1740, S2012

Behaviors select 
Mechanical > 
Elasticity > Elastic 



EXERCISE – Structural Analysis
Property Module

• Define parameters

• Leave Type as 
Isotropic

• Enter 29.7e6 psi as 
Young’s Modulus

• Enter .29 as Poisson’s 
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• Enter .29 as Poisson’s 
Ratio

• NOTE: ABAQUS does NOT 
keep track of units.  It’s your 
responsibility to make sure 
the units are coordinated



EXERCISE – Structural Analysis
Property Module

• Define Section properties

• A Section is a set of 
parameters that 
defines how a 
geometry should be 
treated
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• Solid, homogeneous, 
material, etc.

• Sections are then 
assigned to geometry

• Name the section steel-
1018

• Keep defaults of Solid and 
Homogeneous

• Click Continue…



EXERCISE – Structural Analysis
Property Module

• In the next dialog

• Make sure steel-1018 is 
selected as material

• Un-check Plane 
stress/strain

• Click OK
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• Click OK



EXERCISE – Structural Analysis
Property Module

• Assign the Section

• The Section 
properties must be 
applied to the 
geometry

• Assign > Section
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• Assign > Section



EXERCISE – Structural Analysis
Property Module

• Select the region as shown

• The Edit Section 
Assignment dialog comes 
up

• Make sure the steel-1018 
section is in the Section 
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section is in the Section 
block 

• Click OK



EXERCISE – Structural Analysis
Assembly Module

• Switch to the Assembly 
Module

• Create an Instance of the 
pipe_flange

• Instances allow for 
multiple uses of 
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multiple uses of 
geometry in assembly

• If there’s only one 
part, this isn’t a 
meaningful step

• Click on Instance Part icon

• Leave Instance Type as 
Dependent

• Click OK



EXERCISE – Structural Analysis
Step Module

• Switch to the Step 
Module

• Create a new Load Step 

• Step > Create

• For Procedure type 
select Static, General
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select Static, General

• Click Continue

• We’ll use the defaults for 
the step > Click OK



EXERCISE – Structural Analysis
Step Module

• Select what variable 
should be written to 
output

• Field Output 
Requests - written 
at the end
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• History Output 
Requests - written 
at sub-steps

• Click Field Output 
Requests > Create

• Use pressure as the 
name for the results set

• Click Continue…



EXERCISE – Structural Analysis
Step Module

• There’s a lot of options 
here – let’s stay general

• Domain – Whole 
model

• Frequency – Last 
increment
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increment

• Use Preselected 
defaults for the 
variable selection



EXERCISE – Structural Analysis
Load Module

• In this module we 
establish loads and 
boundary conditions

• BC > Create

• Rename if desired

• Step is Step -1
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• Step is Step -1

• Category > Check 
Mechanical

• Types for Selected Step 
> Displacement/Rotation

• Click Continue…



EXERCISE – Structural Analysis
Load Module

• Select the highlighted 
regions

• Click Done

• Specify the following 
BC’s:

• Displacement u3=0
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• Displacement u3=0

• Rotations about 
u1, u2=0

• Click OK



EXERCISE – Structural Analysis
Load Module

• Select the opposite side

• Click Done

• Specify the following 
BC’s:

• Displacement u2=0
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• Rotations about 
u1, u3=0

• Click OK



EXERCISE – Structural Analysis
Load Module

• Select the flange face

• Click Done

• Specify the following 
BC’s:

• Displacement u1=0
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• Rotations about 
u2, u3=0

• Click OK



EXERCISE – Structural Analysis
Load Module

• Create a pressure load 
on the inside of the pipe

• Load > Create

• Select Pressure for 
Types..

• Click Continue…
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• Click Continue…



EXERCISE – Structural Analysis
Load Module

• Select the face shown

• Click Done

• Use 500 for Magnitude

• Click OK

• SAVE!
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• SAVE!



EXERCISE – Structural Analysis
Mesh Module

• Switch to Mesh module

• Toggle to operate on the 
Part rather than Instance
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EXERCISE – Structural Analysis
Mesh Module

• Prior to creating mesh, 
we need to tell ABAQUS 
approximately how big 
the elements should be

• Seed > Part

• Enter .2 as Approximate 
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• Enter .2 as Approximate 
global size

• Click OK



EXERCISE – Structural Analysis
Mesh Module

• We need to select the 
element type

• Mesh > Element Type

• Select >

• Standard
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• 3D Stress

• Quadratic

• Tet

• Uncheck 
formulation 
options

• Click OK



EXERCISE – Structural Analysis
Mesh Module

• We need to tell ABAQUS 
to use this element type

• Mesh > Controls…

• Click Tet

• Click OK
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EXERCISE – Structural Analysis
Mesh Module

• Create the mesh

• Mesh > Part

• Click Yes
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EXERCISE – Structural Analysis
Mesh Module

• Take a look at the 
mesh we just 
created

• Save
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EXERCISE – Structural Analysis
Job Module

• This module will 
create an input file 
and submit it to a 
solver

• Job > Create

• Click Continue
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• Click Continue

• Accept defaults 
and click OK



EXERCISE – Structural Analysis
Job Module

• Solve the model

• Job > Submit > 
Job-1
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EXERCISE – Structural Analysis
Job Module

• Hopefully you see 
this in the message 
frame
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EXERCISE – Structural Analysis
Visualization Module

• In this module you 
can visualize the 
results just 
computed

• File > Open 

• Select Job -1.odb
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• Select Job -1.odb



EXERCISE – Structural Analysis
Visualization Module

• Click the contour 
button to see the 
results
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